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About This Document 

Purpose 

This guide explains the processes and procedures involved in managing the network using Netspan. It 
does not provide information on how to manage Netspan itself. This is detailed in the Netspan 
Administration Guide. 

Intended Audience 

This guide is intended for the NOC operators who monitors the performance of a unit. Airspan assumes 
that a person performing these instructions is qualified in performing installations and capable of 
identifying hazards. 

Document Conventions 

This document uses the following typographic conventions. 

Table 1. Typographic Conventions 

Convention Element 

Blue underlined text  Cross-reference links. 

Bold text Keyboard buttons and GUI elements. 

Command Command names or phrases. 

Computer output Text displayed by the computer. 

Hyperlinks Website and e-mail addresses. 

Danger 
Signifies a hazardous situation - if not avoided - will 
cause death or serious injury. Describes how to avoid 
it. 

Warning 
Signifies a hazardous situation - if not avoided - can 
cause death or serious personal injury. Describes 
how to avoid it.  

Caution 
Signifies a hazardous situation - if not avoided - can 
void the product warranty, and cause property 

damage. Describes how to avoid it. 

Important Provides necessary information to explain a task. 

Note Provides additional information. 

Tip Provides helpful hints. 

  

http://www.airspan.com/
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Document Organization 

Chapter Contents 

1 Understanding Network Operations 
Provides an introduction to Netspan, and a high level overview 
of the workflow required to make Netspan and the network 
nodes operational. 

2 Netspan Overview 
Explains the Netspan architecture, outlines its functional 
capabilities and describes how to connect to a Netspan server. 
Provides an introduction to the Netspan UI. 

3 Node Discovery 
Explains the process for adding nodes to the network and using 
Netspan to discover them. 

4 Provisioning Describes how to provision service profiles, node profiles, 
nodes, and manage the LTE neighbours. 

5 Configuration Management 
Describes how to manage paging groups, subscriber station, 
network elements, regions, sites, call trace server, Netspan-SF 
server, file server, and SAS server. 

6 Software Upgrade 
Explains how to upgrade the software on a node, including 
adding a software server to Netspan, uploading new software 
to a server and updating a node with that software. 

7 Alarm Management Describes how to view and manage alarms using the Netspan 
UI. 

8 Performance Management 
Explains how to monitor the performance of nodes in your 
network through the Netspan UI. 

9 Node Management 
Describes the node management functionality available within 
Netspan, covering how to view node status, inventory, 

rebooting and reprovisioning.  

10 Event Management 
Explains how to use the Netspan UI to view event types and the 
events that have taken place in your network. 

A Abbreviations 
Lists the abbreviations used in this document and their 
expansions. 

Related Reading 

The following documents contain related information: 

 UGD-D00131 – Netspan Installation and Upgrade Guide  

This document describes the workflow and procedures for installing and upgrading Netspan. 

 ARD-D00741 – Netspan Parameters Reference Guide  

This document describes the parameters required to configure LTE and backhaul nodes using 
Netspan. 

 SYN-PSD-0027 – Netspan NBIF Guide  

This document describes the mechanism implemented in Netspan to interface with the 
customer NOC or OSS through a northbound interface (NBIF). 

 ARD-D00740 – Netspan Counters and KPIs Reference Guide  

This document describes the counters and KPIs that are read from the node population and 
are reported in the Netspan UI. 
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 ARD-D00742 – Netspan Alarms and Events Reference Guide  

This document describes the alarms and events that are raised on the node population and are 
reported in the Netspan UI. 

 UGD-D01018 – Netspan Administration Guide  

This document describes the administrative functions that can be performed in the Netspan UI, 
such as managing users, servers, etc. 

 UG-D01013 – AirCAP Installation and User Guide 

This document guides you on how to use AirCAP for commissioning Airspan’s iB440 wireless 
backhaul solution.   
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Customer Service Help Desk 

Airspan’s Customer Care Help Desk offers prompt and efficient customer support services. To create 
and update issue logs, send e-mails to Customer Care Help Desk. Once you submit your issue, the 
system generates a new issue and sends an issue number for your reference. The system uses this 
issue number to categorize and store e-mails under the appropriate issue.  

Note: To avail Airspan’s Customer Care Help Desk support, you must be a registered user and must 
have a valid support contract. To register, click here and fill the Registration form. 

To help Customer Care Help Desk identify your issue, include the issue number and your Customer 
Care Helpdesk account details in all further communications. 

Main Operations 

Airspan Communications Ltd.  

Capital Point  

33 Bath Road  

Slough, Berkshire  

SL1 3UF, United Kingdom  

Tel: +44-1895-467-100  

Worldwide Headquarters 

Airspan Networks Inc. 

777, Yamato Road, Suite 105 

Boca Raton, FL 3341-4408, USA 

Tel: +1 561 893 8670 

Airspan India 

Airspan Networks India Pvt Ltd. 

Cyber One, 1107/1108, 

S Pranavnandji Marg, Sector – 30, 

Vashi, Navi Mumbai – 400 703. 

Tel: +91 22 2087 8003 

Airspan Encourages Comments 

Airspan welcomes any feedback and suggestions that help to improve the quality of the documentation. 
Send your feedback to documentfeedback@airspan.com.  

mailto:helpdesk@airspan.com
https://support.airspan.com/SignUp.jsp?account=airspan
mailto:documentfeedback@airspan.com
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1 Understanding Network Operations 

This document provides the operational workflows and information on how you use Netspan (Airspan’s 
EMS) for adding, discovering, and provisioning nodes and subsequently monitoring their performance. 
Netspan is a client-server application that consists of an SQL database server, web server, and a set 
of always-on services.  

Netspan is a comprehensive element manager, which is designed around a client-server architecture. 
The Netspan server runs on a server platform and uses an SQL database to store the configuration and 
statistics. 

To understand the processes and operations detailed in this document, you need a basic working 
knowledge of the unit and a broad understanding of the network and routing principles, and network 
configuration. 

Though the framework of each network is unique, following are the fundamental operational processes 
involved in the workflow: 

1. Installing Netspan 

2. Adding and discovering nodes 

3. Provisioning nodes 

4. Controlling and monitoring the nodes 

Figure 1 illustrates the flow of network operations. 

Figure 1: Network Operations Workflow 

 

Netspan provides an intuitive interface simplifying the management of even the most complex and 

crucial networks. 

Note: In this document, iBridge LOS refers to iBridge 440 and iBridge NLOS refers to 460. 
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2 Netspan Overview 

Netspan is designed to assist you with regulating, unifying, and simplifying the network management 
operations in heterogeneous environments, including the Airspan nodes. 

The Netspan server is accessed using a web browser (for example, Internet Explorer), with all 
functionality and element management provided through web pages. 

Figure 2 shows the Netspan architecture. 

Figure 2: Netspan Architecture 

 

The NOC operators are assigned with a role that is appropriate for their function. The Netspan clients 
operate remotely from the Netspan server. Use a Netspan client to discover and provision a unit. 
Netspan is a complete management system that supports a variety of high-level operations for huge 
networks. It provides the following functions: 

 Fault management 

 Configuration management 

 Alarm handling 

 Performance management 

 Security management  
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2.1 Connecting to Netspan Server 

This section explains how to install Netspan and connect to the Netspan server. You can download the 
latest version of Netspan from ShareMethods or Airshare, Airspan’s product information portal. For 
more information on how to install Netspan, see UGD-D00131 Netspan Installation and Upgrade Guide. 

If you are trying to connect to the Netspan server from a server PC, do one of the following: 

 Connect as a localhost: 

o Open the web browser. 

o Type localhost/Netspan in the address bar. 

o Press Enter. 

 Connect using the Netspan server IP address: 

o Open the web browser. 

o Type the Netspan server IP address in the address bar. 

o Press Enter. 

 If you are trying to connect to the Netspan server from a client PC, perform the following 
steps: 

o Open the web browser. 

o Type the Netspan server IP address or Netspan’s server hostname in the address bar. 

o Press Enter. 

2.2 Navigating Netspan UI 

The Netspan UI is extremely flexible, allowing you to navigate to screens in multiple ways depending 
on the task you are performing. The menu structure on the left of the UI provides you with logical 
groupings to navigate to a particular screen and action. 

Figure 3: Netspan Main Menu 

 

  

https://www.sharemethods.net/
https://airshare.airspan.com/
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In addition, a quick-links menu is permanently available at the bottom left corner of the navigation pane. 

Figure 4: Netspan Quick Links Menu 

 

Each of these options present you with real-time information regarding the current state of operation of 
your network, as reported to Netspan. Where applicable, these quick menus also provide you with direct 
links to the corresponding screen in the Netspan UI. For example, clicking the Alarms entry opens the 
Active Alarms screen. 

To understand the data displayed in the quick links panel, hover your cursor over one of the numbers 
shown. A tooltip is displayed explaining what that number represents. Table 2 contains a full explanation 
of the links and data in the quick links menu. 

Table 2. Quick Links Menu 

Quick Links Menu Title Category Title Links to… Statistics Shown 

Alarms 

 

Critical Active Alarms screen Total number of critical alarms. 

Major Active Alarms screen Total number of major alarms. 

Minor Active Alarms screen Total number of minor alarms. 

Warning Active Alarms screen Total number of warning alarms. 

2.2.1 Layout Options 

At the top, right corner of most Netspan screens is a set of Layout options. These vary slightly 
depending on the nature of the screen being displayed, but provide you with the ability to change the 
appearance of the screen and once you have, either revert to the original settings or save your changes. 

Figure 5: Layout Options 

 

The function of these buttons is explained in Table 3. 

Table 3. Layout Button Functions 

Button Name (shown in tooltip) Function 

 

Toggle row appearance for 
rows with alarms 

Only available on certain screens, this button enables you to 
convert the whole table display to be colour coded to make it easy 
to identify the rows that contain critical, major, and other severities 
of alarm. In the normal display, the colour coding is limited to the 
triangular icon next to the node name or alarm ID. 
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Button Name (shown in tooltip) Function 

 

Click the Toggle rows button and the whole table is coloured 

according to the severity of the alarm in each row. 

 

In this display, the appearance of the button changes ( ). Click it 

again to revert to the previous display.  

See How to Understand Alarm Details for further information 
regarding the colour coding of alarms. 

 

Reset column ordering, 
width, and sorting 

Resets column order, column width, and also allows you to sort 
the data. This option provides you with the ability to change the 
appearance of the screen to default. 
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3 Node Discovery 

Node discovery is the process through which Netspan becomes aware of the presence of a newly 
installed node in a network and establishes first contact with that node. 

Note: This process is only relevant for manually installed devices and is not relevant for PnP nodes. 

In order to discover new nodes for Netspan, these nodes first need to be commissioned and made 
available in the network. Once they are present, you can instruct Netspan to find them by creating and 
initiating a discovery task. 

This section explains how to add nodes to the network and subsequently discover them. Once they 
have been discovered, you are then able to provision them ready for operation. The provisioning of 
nodes is covered in Provisioning. 

Figure 6: Node Discovery Flowchart 

 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

  

Has a new 
node been 

configured and 
added to the 

network? 

No 

Yes 

Configure and add a node 

Enable node discovery in 
Netspan 

Provision the node 

Is a discovery 
task enabled 

to find the 
node? 

No 

Yes 
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This chapter covers the following topics: 

 How to Enable Discovery on a Node 

 How to Discover a Node in Netspan 

 How to Disable Node Discovery 

 How to Delete a Node Discovery Task 

 How to Edit a Node Discovery Task 

 How to Clone a Node Discovery Task 

 Node Search 

 Node RF 

 Node Usage Count 

 Column View Editor 

 Node Map 

3.1 How to Enable Discovery on a Node 

To enable Netspan to discover a node on your network, you must first add and configure that node. 

Note: Airspan assumes that the personnel performing this configuration has a basic knowledge of the 
process. The process explained here is applicable to nodes of the type eNodeB, iBridge2, iBridge 
NLOS, or iRelay. 

To add a node: 

1. Connect the node to a network accessible to the Netspan server. 

2. On the node terminal, open a browser instance and enter the address of the web page to 
configure node’s connection. 

3. Set the configuration parameters for a particular node type. Note that the exact set of 
parameters you need to define will vary depending on the node type you are configuring. To 
illustrate the potential variances in the fields you may see Figure 7, Figure 8, and Figure 9 which 
show different configuration screens for a mobile LTE base station, an Air4G eNodeB terminal, 
and an iBridge 460 local terminal. 

Figure 7: Configuring a Mobile LTE Base Station 

 



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  19 

For more information on the configuration parameters, see Table 4. 

Table 4. Mobile LTE Base Station Node Configuration Parameters 

Parameter Description 

IP Configuration Parameters 

Plug-n-Play Enable 

Specifies whether PnP is enabled or disabled. This needs to be 
disabled (checkbox cleared) in order to manually discover the 
node. If PnP is enabled, the node will be auto-discovered by 
Netspan and the rest of this procedure will not be required. 

IP Address Specifies the management IP address of the node. 

Subnet Mask Specifies the subnet mask of the node. 

Default Gateway Specifies the default gateway of the node. 

Management VLAN 
By default, the management VLAN will be Untagged. If your 
network includes a management VLAN, select Tagged. 

VLAN Tag Id 
Specifies the management VLAN ID if you have selected the 
Tagged option for the management VLAN. 

SNMP Agent Configuration Parameters 

SNMP Version Specifies the SNMP version to use, either V2C or V3. 

Read Only Community 

Specifies the appropriate Read Only permission. 

Note: This community string value must be identical to the one 

you specified in Netspan when creating relevant Discovery task. 

Read Write Community 

Specify the appropriate Read Write permission. 

Note: This community string value must be identical to the one 

you specified in Netspan when creating relevant Discovery task. 

SNMPv3 Access 

Specifies the SNMP rights.  

Note: You can set a value for this parameter only if SNMP 
Version = Version 3.  

SNMPv3 Password 

Specifies the SNMP community string [SNMPv2] or password 
[SNMPv3].  

Note: You can set a value for this parameter only if SNMP 
Version = Version 3.  

BS Mgmt SNMP Port 
If you leave this field empty, the node uses default SNMP port 
number (i.e. 161) to communicate with Netspan. 
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Figure 8: Configuring an Air4G eNodeB Terminal 

 

For more information on configuration parameters, see Table 5. 

Table 5. Air4G eNodeB Configuration Parameters 

Parameter Description 

SNMP Agent/Trap Configuration 

SNMP V2 
Select the SNMP version to use, either V2 or V3. It is 
recommended to use V2. The radio buttons for each SNMP version 
are mutually exclusive. 

Read Only Community 

Specifies the appropriate Read Only permission. 

Note: This community string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

Read Write Community 

Specify the appropriate Read Write permission. 

Note: This community string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

SNMPv3 Access 

Specifies the SNMP rights.  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  

SNMPv3 Password 

Specifies the SNMP community string [SNMPv2] or password 
[SNMPv3].  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  
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Parameter Description 

Read Only Password 

Specifies the appropriate Read Only password. 

Note: This password string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

Read Write Password 

Specify the appropriate Read Write password. 

Note: This password string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

Transport Type Define the transport type to be used. 

BS Mgmt SNMP IP SNMP IP address to use to communicate with Netspan. 

BS Mgmt SNMP Port 
If you leave this field empty, the node uses default SNMP port 
number (i.e. 161) to communicate with Netspan. 

Trap Dest IP Addr The IP address to send trap information to. 

Trap Port Number The IP number to communicate trap information on. 

Airsync Server Configuration 

NMS Type 
Network Management System used to control the node. Select 
Netspan. 

Airsync Server IP IP address of the Airsync server. 

Figure 9: Configuring an iBridge 460 local terminal 
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For more information on configuration parameters, see Table 6. 

Table 6. iBridge 460 Node Configuration Parameters 

Parameter Description 

IP Configuration  

IP Allocation 
Select the IP allocation method for the node. This will usually be 
Static. 

IP Address Specifies the management IP address of the node. 

Subnet Mask Specifies the subnet mask of the node. 

Default Gateway Specifies the default gateway of the node. 

SNMP 

SNMP Port - Application 
Agent 

SNMP port used for the application agent. 

SNMP Port - Board Agent SNMP port used for the board agent. 

SNMP Version 
Specifies the SNMP version to use, either V2 or SNMPv3. It is 
recommended that you select either V2. 

SNMPv3 Access 

Specifies the SNMP rights.  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  

SNMPv3 Password 

Specifies the SNMP community string [SNMPv2] or password 
[SNMPv3].  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  

Read Only Community 
Specifies the appropriate Read Only permission. 
Note: This community string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

Read Write Community 
Specify the appropriate Read Write permission. 
Note: This community string value must be identical to the one you 

specified in Netspan when creating relevant Discovery task. 

Ethernet Port 

Mode Defines the mode for Ethernet port discovery. 

Management VLAN 

Tagging Behaviour 
If your network includes a management VLAN, select Tagged. 
Otherwise, select Untagged. 

4. Click Submit (or Save, depending on the button shown on the screen) to commit your 
configuration settings. 

5. Reboot the node to apply the IP configuration. 

Note: For more information on setting the IP connectivity, see appropriate node 
commissioning manual. 
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3.2 How to Discover a Node in Netspan 

Once you have a node that is commissioned and available in your network, as described in How to 
Enable Discovery on a Node, you need to instruct Netspan to find that node by initiating a node 
discovery task. 

To enable node discovery on Netspan: 

1. On the main Netspan menu choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system. 

Figure 10: Discovery Tasks List Screen 

 

2. To enable a configured task which is not currently active, click on the task in the list to select it 
and click Enable. The checkbox in the Enabled column will now be ticked for your nominated 
task and an information message will be displayed at the bottom of the Netspan screen, stating 
that your discovery task is now enabled. 

3. Alternatively, you can create a new discovery task. To do this, click Add below the task list. 
This opens the Add Discovery Task screen. 

Figure 11: Add Discovery Task Screen 
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4. Complete the fields according to the descriptions provided in Table 7. 

Table 7. Add Discovery Task Parameters 

Parameter Description 

General Properties 

Name 
Enter a name for the discovery task you are creating. This needs to 
be a string of 2-64 unicode characters excluding ‘<’, ‘&’, and leading 
or trailing spaces. 

Enabled 
Whether your task is to be enabled immediately on creation. You can 
define the task now, but enable it at a later time by leaving this 
checkbox unchecked. 

SNMP Properties 

SNMP Timeout 

Specify the SNMP timeout value for the discovery task. Select the 
Use Defaults checkbox to automatically populate the value or clear 

the checkbox and enter a value in the range from 1 to 20. Values are 
in seconds. 

SNMP Version 
Select the SNMP version to use from the drop-down list, either 
SNMPv2C or SNMPv3. The recommended value is SNMPv2C. 

Access 

Specifies the SNMP rights.  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  

Read Write Password 

Specifies the SNMP community string [SNMPv2] or password 
[SNMPv3].  

Note: You can set a value for this parameter only if SNMP Version 
= Version 3.  

Write Community 

Enter the write community applicable to the task. This needs to be a 
string of 1-64 characters from a-z, A-Z, 0-9, and special characters -
_,.;:#@/. This value needs to exactly match the write community 
value defined when the node was commissioned (see How to Enable 
Discovery on a Node for details). If the entries here and on the node 
do not match, then Netspan will not be able to discover the node. 

Read Community 

Enter the read community applicable to the task. This needs to be a 
string of 1-64 characters from a-z, A-Z, 0-9, and special characters -
_,.;:#@/. This value needs to exactly match the read community 
value defined when the node was commissioned (see How to Enable 
Discovery on a Node for details). If the entries here and on the node 

do not match, then Netspan will not be able to discover the node. 

IP Address and Ports 

IP Addresses 

Specify the IP address(es) of the node(s) to be discovered.  

 For IPv4 this will be in the form n.n.n.n, where n is an 

integer ranging from 0 to 255. 

 For IPv6 this will be in the form x:x:x:x:x:x:x:x. 

Click the add button ( ) to define multiple IP addresses. Where you 

enter multiple addresses, Netspan pings each address in turn to try 
to find the defined node. 

Note: Regardless of whether you are using IPv4 or IPv6 addresses, 

you can define an address range in instances where you want to ping 
multiple addresses. After entering the first address, click the add 

button to indicate that you want to enter multiple addresses. Rather 
than having to enter each address individually, a second entry field 
will be shown next to the main IP address field with the word ‘to’ in 
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Parameter Description 

between. Enter the last IP address of the range you want to examine. 
Netspan will ping each address from your range. 

For IPv4, it is recommended to limit the IP address range to 1024 IP 
addresses as a large range can cause Netspan to slow down.  

For IPv6, a maximum range of 1024 IP addresses (/118) can be 
entered per Discovery Task.  

Ports 
Specify the UDP port used by the node to be discovered. Click the 
Add button ( ) to define multiple ports. 

5. Once you have defined your discovery task, a Test panel will be displayed at the bottom of the 
screen. If you want to try your discovery task to see if it reaches the node(s) you are trying to 
discover, click Test in this panel. Results will be returned, showing whether the node has been 
discovered by Netspan. 

Figure 12: Discovery Task Test 

 

6. Click OK to add your discovery task to the task list. You will be returned to the Discovery Tasks 
screen. 

7. If you have created your task in step 3 without choosing to enable it from creation, you can now 

choose it in the task list and enable it manually as described in step 2.  
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3.3 How to Disable Node Discovery 
There may be occasions when you want to disable a node discovery task, for example: when you want 
to change the parameters of a task or when the task has been running and the required nodes have 
been discovered.  

To disable node discovery: 

1. On the main Netspan menu, choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system. 

Figure 13: Discovery Tasks List Screen 

 

2. To disable a discovery task that is currently active, click on the required task (or tasks, if you 
want to disable multiple tasks at once) in the list to select it and click Disable. The checkbox in 
the Enabled column will now be cleared for your nominated task and an information message 
will be displayed at the bottom of the Netspan screen, stating that your discovery task is now 
disabled. 

3.4 How to Delete a Node Discovery Task 

There may be occasions when you want to delete a node discovery task, for example when the task 
has been running and the required nodes have been discovered. 

To delete a node discovery task: 

1. On the main Netspan menu, choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system. 

Figure 14: Discovery Tasks List Screen 
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2. To delete a discovery task, click on the required task (or tasks, if you want to delete multiple 
tasks at once) in the list to select it and click Delete. Your task will be removed from the list.  

3.5 How to Edit a Node Discovery Task 

There may be occasions when you want to edit an existing node discovery task, for example to change 
the IP address of the node you want to discover. 

To edit a node discovery task: 

1. On the main Netspan menu, choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system. 

Figure 15: Discovery Tasks List Screen 

 

2. Click on the task in the list to select it and click Edit. The Edit Discovery Task screen will be 
displayed with the details of your selected task pre-populated. 

Figure 16: Edit an Existing Discovery Task 
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3. Change the parameters of the task as required. Refer Table 7 for more information on the 
values you can enter. 

4. If you want to test your revised discovery task, click Test in the Discovery Test panel. The 
results of your test will be displayed on the screen. 

5. Click OK to commit your changes and return to the Discovery Tasks list screen. 

3.6 How to Clone a Node Discovery Task 

There may be occasions when you want to clone an existing node discovery task rather than creating 
one from scratch. This generates a discovery task, with identical parameter values to the original task, 
which you can edit to make the task unique. 

To clone a node discovery task: 

1. On the main Netspan menu, choose Server > Discovery Tasks. This displays the Discovery 
Tasks screen, which shows a list of all discovery tasks currently defined in your system. 

Figure 17: Discovery Tasks List Screen 

 

2. To clone a discovery task, click on the required task in the list to select it and click Clone. The 
Add Discovery Task screen will be displayed with the details of your selected task pre-
populated. 

Figure 18: Add Discovery Task Screen for Cloning 
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3. Change the parameters of the task as required to create your new task. Refer Table 7 for further 
information about the values you can enter. 

4. If you want to test your new discovery task, click Test in the Discovery Test panel. The results 
of your test will be displayed on the screen. 

5. Click OK to commit your changes and return to the Discovery Tasks list screen. 

3.7 Node Search 

Through multiple orders of filtering, the Node Search feature enables you to reduce the list of nodes to 
just those you are interested in. The list of nodes is automatically filtered based on your selected criteria. 

You can use this feature to edit, manage, upgrade the software, export, or reload the filtered list of 
nodes as a batch. For detailed instructions on how to perform node search effectively, see Performing 
Node Search. 

Figure 19: Filtered List of Nodes – Edit All, Manage All, Software All, Export, Reload 

 

3.7.1 Performing Node Search 

This section explains how to perform some of the most intuitive tasks to enhance your node search and 
to filter a list of nodes configured in your network. 

To search for specific nodes operating on your network: 

1. On the main Netspan menu, choose Configuration Management > Node > Node Search. 
This displays the Node Search page. 

Figure 20: Node Search Screen 
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2. Select the Node Type drop-down list to display all the available node types deployed in your 
network. From this list, select the appropriate node type that you want your search to return. 
Figure 21 shows the expanded view of the Node Type drop-down list. 

Figure 21: Selecting the Node Type 

 

3. The View Type drop-down list gives you the options to view the data in either tabular or 
graphical format by setting it to Grid or Chart, respectively. In either case, you have the option 
to use multiple filter features. The default View Type is Grid. 

Figure 22: Selecting the View Type 

 

Figure 23 shows an example node search where the View Type is Grid. 

Figure 23: Node Search Screen – Tabular Format 

 

Figure 24 shows an example node search where the View Type is Chart. When the View Type 
is set to Chart, you can find the chart element drop-down list in the bottom left corner of the 
Node Search page. 

You can see your chart rendered in the Donut, Column, or Bar format by making the 
appropriate chart element selection. The display is automatically updated each time you select 
a different chart element. 
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Figure 24: Node Search Screen – Graphical Format 

                         

4. To limit your node search to a specific System, User, or Global property, select an appropriate 
entry from the View drop-down list. 

You cannot modify and save a System view, but you can save the modified System view as a 
User or as a Global view for future use. For more information on how to create a User or Global 
view, see Table 8. 

Netspan retains the node type and filtering criteria when switching between view types. 

Figure 25: Selecting a View 

 

To refine your search further and to narrow down your results, select the Edit checkbox next to 
the View drop-down list. The Edit View uses industry standard mechanisms to add and remove 
properties from a filter list. You can modify the Edit View by adding or removing properties from 
the available categories. The Edit View panel also contains options to search, reset, delete or 
save a view. For more information on these actions, see Table 8. 

Node search view provides a method to generate a subset of the actual available data. By 
creating several node search views, you can produce many subsets of data from the same 
information source. 
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Figure 26: Node Search – Edit View 

 

Table 8. Edit View Properties 

Property Description 

Category 

Lists the properties that are associated with the 
selected category. 

Note: You can alphabetically sort the pre-
populated categories by selecting All (sorted 
alphabetically) from the Category drop-down 

list. 

Properties 

Lists the properties that are populated in the 
search result grid or chart. 

Note:  

 If the View Type is Chart, the maximum 

number of entries you can add to the 
Properties list is three. 

 The order of the properties in your 
search result depends on the sequence 
of the entries in this list. 

Add 

Adds entries from the Category list to the 
Properties list. It allows you to customize your 

view by adding the node properties that you want 
to include in your search result. 

Procedure: 

a. Click to select the entries that you want 
to add to the Properties list. 

Tip: Use Ctrl + click to select multiple 
entries and Shift + click to select an 

array of entries. 

b. Click Add. 

The selected properties are now added 
to the Properties list. 

Remove 

Removes entries from the Properties list. It 

allows you to customize your view by removing 
the node properties that you do not want to 
include in your search result. 

Procedure: 

a. Click to select the entries that you want 
to remove from the Properties list. 



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  33 

Property Description 

Tip: Use Ctrl + click to select multiple 
entries and Shift + click to select an 

array of entries. 

b. Click Remove. 

The selected properties are now 
removed from the Properties list. 

Move to Top ( ) 
Moves the property to the top of the Properties 

list. 

Move Up ( ) 
Moves the property above the preceding item in 
the Properties list. 

Move Down ( ) 
Moves the property below the succeeding item in 
the Properties list. 

Move to Bottom ( ) 
Moves the property to the bottom of the 
Properties list. 

Search 
Displays the updated view of the search result. 
This button is enabled only when the Edit View 

is modified. 

Reset View Resets the search to the original view. 

Delete View 

Deletes the selected view. 

Note:  

 You cannot delete a System view. 

 This button is enabled only when a 
user-defined view is selected. 

 To delete a Global view, you need 
administrator privileges. 

Save View 

Saves the changes that you made to the selected 
view. 

Note:  

 This button is enabled only when a 
user-defined view is selected. 

 You cannot save changes made to a 
System view. If the selected view is 
from the System category, this button is 
greyed out. However, you can save the 
modified System view as a User or 
Global view. 

 You can save the changes made to a 
selected Global view only if you are a 
user with administrator privileges. 

Save As 

Saves the selected view. Netspan allows you to 
save a specific view for future use. This option 
allows you to save the customized information 
and set it as a User or Global view. 

Procedure: 

a. After customizing your Properties list 

(by adding or removing properties for a 
selected category), click Save As. 

b. In the Save As box, specify a name for 

the view that you are creating. 
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Property Description 

c. Click Save or Save Global depending 

on what view you want to create. 

For more information, see the description in the 
Save As > Save and Save As > Save Global 

fields in this table. 

Note:  

 You need administrator privileges to 
save your preferences as a Global view. 

 The name of a view should be unique. 

 The saved User views appear in the 
View drop-down list under the User 

category. 

For example, Test 1 is a user-defined 

view. 

 

Save As > Save 

Completes the Save As action. 

Note: This button appears only when you select 
Save As. 

Save As > Save Global 

Creates a Global view that is visible to all users. 
Use this option when you want to share a view 
with other users, for example, a view that is 

useful for the entire organization. 

You need administrator privileges to create, 
delete, or modify a Global view. 

Note:  

 The saved Global views appear in the 
View drop-down list under the Global 

category. 

 

 This button appears only when you 
select Save As. 

Cancel Save 

Cancels the save action. 

Note: This button appears only when you select 
Save As. 

You can enhance your node search based on your requirement by making an appropriate 
selection from the Filter drop-down list. To further refine your search process, select the Edit 
checkbox next to the Filter drop-down list. 

The Edit Filter panel also contains options to search, reset, delete or save a filter. For more 
information on these actions, see Table 9. 
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Figure 27: Node Search – Edit Filter 

 

Table 9. Edit Filter Properties 

Property Description 

Category 

Specifies the property based on which you want 
to sort your search. 

Note: You can alphabetically sort the pre-
populated categories by selecting All (sorted 
alphabetically) from the Category drop-down 

list. 

Property 
A list of properties associated with the selected 
category. 

Compare Type 

Enhances the filter criteria by offering the ability 
to select specific parameter values. 

For more information on compare types and their 
significance, see Table 10. 

Value 
A pre-populated list of values that are valid for 
the selected property. 

 
Clones the filter item. Use this option to add 
subsequent filters and refine the previous filters. 

 Deletes the filter item. 

3.7.2 Filter Compare Types 

When you select the Edit Filter option, you can select a property to filter by, a compare type, and a 
value. 

Compare types enhance the search process by offering the ability to select specific parameter values. 
Depending on what comparison you want to perform, select the compare type. Each compare type has 
a unique function that is designed to make your node search simple, easy, and effective. 

Before using a compare type, it is important to understand its purpose. 
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Figure 28: Available Compare Types 

  

Table 10. Compare Type Function 

Compare Type Function 

= Returns a list of nodes where the selected property matches the set value. 

!= Returns a list of nodes where the selected property does not match the set value. 

> Returns a list of nodes where the selected property is greater than the set value. 

>= 
Returns a list of nodes where the selected property is greater than or equal to the 
set value. 

< Returns a list of nodes where the selected property is smaller than the set value. 

<= 
Returns a list of nodes where the selected property is smaller than or equal to the 
set value. 

Starts with 
Returns a list of nodes where the selected property starts with the substring that 
you specified in the Value field. 

Contains 
Returns the details of the nodes where the selected property contains the 
substring that you specified in the Value field. 

Not Contains 
Returns the details of the nodes where the selected property does not contain the 
substring that you specified in the Value field. 

In List 

Returns the details of the nodes where the selected property matches the values 
that you selected/typed/pasted using the Set List option. 

Tip: Use Ctrl + click to select multiple entries and Shift + click to select an array 

of entries. 

Note: Instead of selecting the items, if you want to type or paste a list of values, 
after selecting the Set List button, click the Advanced button. This opens a new 

window where you can type or paste your items. 

When you are in the Advanced mode, click the Basic button to revert to the 
Basic mode. 

Not in List 

Returns the details of the nodes where the selected property does not match the 
values that you selected/typed/pasted using the Set List option. 

Tip: Use Ctrl + click to select multiple entries and Shift + click to select an array 

of entries. 

Note: Instead of selecting the items, if you want to type or paste a list of values, 
after selecting the Set List button, click the Advanced button. This opens a new 

window where you can type or paste your items. 

When you are in the Advanced mode, click the Basic button to revert to the 
Basic mode. 

Is Set Returns the details of the nodes where the selected property is defined or set. 

Is Not Set Returns the details of the nodes where the selected property is not defined or set. 
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The list of applicable compare types varies depending on the selected Category and Property. For 

more information, see the following examples. 

Examples: 

Figure 29 shows the list of applicable compare types and values when Category = Node and Property 
= Max Alarm Severity. 

Figure 29: Example 1 ─ Applicable Compare Types 

 

Figure 30 shows the list of applicable compare types and values when Category = Node and Property 
= Managed. 

Figure 30: Example 2 ─ Applicable Compare Types 

 

3.7.3 Node Search Examples 

This section lists some scenarios where you can use this feature to make your node search simple and 
easy. 

 Case 1: To find all eNodeB that have hardware type as AirStrand 1300. 

Figure 31: Node Search ─ Case 1 
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 Case 2: To find all eNodeBs that are Managed. 

Figure 32: Node Search ─ Case 2 

 

 Case 3: To find all the nodes whose Max Alarm Severity is Critical. 

Figure 33: Node Search ─ Case 3 
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 Case 4: To find Management Profile whose Statistics Collection is Enabled. 

Figure 34: Node Search ─ Case 4 

 

 Case 5: To find all nodes that have the specified custom property added to the Node 
Properties panel of the Node Provision page. 

For guidance on how to add custom node properties, see the Netspan Administration Guide 
(ARD-D01018). 

Perform node search to filter out the nodes with the specified custom property value. 

Figure 35: Searching for the Nodes with the Specified Custom Property Value 

 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  40 

 Case 6: To find all nodes that belong to a specific node group. 

For guidance on node groups, see the Netspan Administration Guide (ARD-D01018). 

Perform node search to filter out the nodes with the specified node group name. 

Figure 36: Searching for the Nodes Belonging to a Specific Node Group 

 

3.8 Node RF 

1. On the main Netspan menu, choose Configuration Management > Node > Node RF. This 
displays the Node RF screen, which shows a list of nodes. 

Figure 37: Node RF List 
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3.8.1 Editing a Node 

1. Select the node that you want to edit and click Edit. 

Figure 38: Edit Node Screen 

 

2. The Edit Node screen will be displayed. Make the changes and click Save. 

Figure 39: Edit Node Screen 
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3.8.2 Deleting a Node 

1. Select the node that you want to delete and click Delete. 

Figure 40: Deleting a Node 

 

3.8.3 Exporting Nodes in Excel File 

1. Click Export to export the nodes held in Netspan’s database. Your browser will show a 
message asking whether you want to open or save Export.csv, the Excel file generated by 
Netspan for export. Click Open or Save as appropriate. 

Figure 41: Export Excel File Message 

 

2. If you choose Open, your machine will launch Excel and will display the exported file with 
details.  

Figure 42: Excel File View 
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3. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 43: Export Confirmation Message 

 

3.8.4 Reloading a Page 

Clicking the Reload button on an active page prompts Netspan to retrieve real-time information from 
the node and update data on that page. 

Note: The process for opening or saving the file is the same for Export View and Export All. 

To refresh a page, click the Reload button. 

Figure 44: Page Reload Options 

 

Tip: To enable automatic reload, select 15 s, 30 s, or 60 s from the drop-down list next to the Reload 
button. 

3.9 Node Usage Count 

1. Go to Node Profiles and select the profile for which you want to view the nodes. 

Figure 45: Selecting Profile 
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2. Click View Nodes to see the nodes using this profile. 

Figure 46: Viewing Nodes 

 

3. Netspan will redirect to Node Search page and will display all the nodes using this profile. 

Figure 47: Node Search Page 

 

3.10  Column View Editor 

1. A view editor has been added to customize the column names user wants to view. Click on 
Configure Columns as shown below. 

Figure 48: eNodeB List 
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2. After clicking on Configure Columns, a popup screen will be displayed to customize fields for 
viewing. 

Figure 49: Configure Columns 

 

3. Additionally, the node list page has been enhanced with the filter feature that allows the user to 
search a node by using different filter conditions. Click Filter checkbox to view this feature. 

Figure 50: Node Filter Feature 
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3.11  Node Map 

The node map provides a visual representation of the location of the nodes on a map. To view the node 
map, from the Netspan main menu, select Configuration Management > Node > Node Map. 

Figure 51: Node Map 

 

When the nodes are very close to each other, they cluster into one map point. The number on a cluster 
indicates how many nodes it contains. 

When you zoom into any of the cluster locations, the number on the cluster decreases and you begin 
to see individual nodes on the map. Zooming out of the map consolidates nodes into clusters again. 

Figure 52: Node Clusters 

 

The colour of a cluster is taken from the colour of the highest alarm severity for the nodes within that 
cluster. 

3.11.1 Map Navigation 

You can use the mouse or keyboard for panning and zooming the node map. The node map supports 
the following actions: 

Using your mouse: 

 Wheel the mouse forward to zoom in. 

 Wheel the mouse backward to zoom out. 
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 Drag the mouse to move around. 

 Shift + drag the mouse to zoom in to a specific area on your map. 

 Double-click to zoom in. 

Using your keyboard: 

 Use the arrow keys to move around. 

 Use ‘Ctrl’ + ‘+’ key to zoom in. 

 Use ‘Ctrl’ + ‘–‘ key to zoom out. 

3.11.2 Zoom In and Zoom Out 

Netspan allows you to reduce or enlarge the node map view. At the top left corner of the Alarm Map 
page: 

 Click  to get a closer look at the nodes and links. 

 Click  to zoom out and cover more area. 

To increase or decrease the zoom value, keep clicking the Zoom In or Zoom Out button until you 
obtain the expected zoom level. 

3.11.3 Fit to Extent 

It sets the zoom and location of the map to accommodate all nodes. It gives you the ability to keep the 

map extent constant. To fit to extent, click the  icon on your map. 

3.11.4 Saving Your Custom Map View 

The node map saves any custom map settings you made before navigating to a different page or logging 
out from Netspan. When you reopen the node map, Netspan automatically applies your custom map 
settings that were in use when you last viewed the node map. 

3.11.5 Internode Link Status 

For node types where Netspan supports internode link status (for example, iBridge products with a base 
and a terminal) the map displays the links with a colour reflecting the link status. 

Figure 53: Node Map ─ Internode Link Status 
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3.11.6 Selecting Nodes 

The node map feature provides you an alternative to select multiple nodes and manage them easily, 
rather than doing it from the All Nodes List (Configuration Management > Node > Node). Compared 
to the standard way of selecting nodes from the All Nodes List, this advanced functionality can be 
more useful in situations where you want to select nodes from a specific location. 

Note: Airspan recommends to use this feature to perform location-based node services. 

 

Note: When you select a cluster, all nodes in that cluster are selected. 

To select multiple nodes from the node map and manage them, you can use one of the following 
methods: 

Method 1: 

This method is ideal when you want to select specific nodes in a location. For example, you might want 
to exclude some nodes, but select others that are in the same location. 

Table 11. Cursor Actions ─ Single Select 

Purpose Action 

To select a single node or cluster 
Click the node or cluster you want to select. A 
selected node/cluster is marked with a blue circle.  

To select multiple nodes or clusters 

Click to select one node or cluster first, and then Ctrl-
click to select each additional node/cluster you want 

to select. 

To clear the entire selection 
Click anywhere on the map to deselect all selected 
nodes or clusters. 

To deselect a node or cluster from the selection 

Ctrl-click the node or cluster you want to deselect. 

This action allows you to deselect a node/cluster 
without disturbing the selection made to other nodes 
or clusters. 

The Selected Nodes pop-up window appears automatically when at least one node or cluster is 
selected. This window contains the details of the selected nodes. 
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Figure 54: Selected Nodes 

 

Method 2: 

This method is optimal for situations where you want to select a collection of nodes or clusters in a 
location. 

1. At the top right corner of the Node Map page, select Multi Select. 

Note: Adjust the zoom level to see the nodes or clusters you want to select. 

2. When you select the Multi Select option on the map, to enhance affordance and usability, the 

mouse pointer changes to a hand cursor ( ). 

3. Use this hand cursor to draw a polygon or an enclosed shape (with all the sides connected up) 
surrounding the nodes and clusters that you want to select. 
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Figure 55: Selecting Multiple Nodes ─ Example 1 

 

Figure 56: Selecting Multiple Nodes ─ Example 2 
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4. Perform the actions in Table 12 to make a polygon or an enclosed shape surrounding the nodes 
and clusters that you want to select. 

Table 12. Cursor Actions ─ Multi Select 

Action Result 

Single-click Extends the selection area. 

Double-click 
Ends drawing the area and selects all nodes and 
clusters in it. 

Ctrl-click + drag 

Draws a frame to define an irregular area and selects 
the nodes and clusters within it. 

Tip: To resize the area and make alterations, single-

click and drag the borders of the shape in the desired 
direction. 

The selected nodes and clusters within the shape are marked with a blue circle. When you 
finish creating a polygon or drawing an irregular area, the Selected Nodes pop-up window 
appears. It contains the details of the selected nodes. 

3.11.7 Managing Multiple Nodes Using Node Map 

After selecting the nodes (see Selecting Nodes), click Manage at the bottom of the Selected Nodes 
pop-up window. 

Figure 57: Manage Nodes Option 

 

This action takes you to the Multiple Node Management page, which allows you to perform various 
management actions (for example, view alarms and events list, view status information and so on) on 
the selected nodes. 

Figure 58 shows the Node Management page with various node management tabs that you can use 
for managing multiple nodes that you selected (see Figure 57) using the Netspan Node Map feature. 
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Figure 58: Multiple Node Management Page (Example) 

 

3.11.8 Exporting Map View to External Maps 

Netspan also supports .kml and .kmz file import and export. This feature allows customers to import 
and export map information to and from the external maps. 

Note: To enable this feature, you need a suitable Netspan licence. 

To export the map view: 

1. At the top right corner of the Node Map page, select KML or KMZ. 

Figure 59: Selecting KML/KMZ 
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2. A message asking whether you want to open or save the exported file appears. Click Open or 
Save (as appropriate). 

Figure 60: Export Excel File Message 

 

o If you choose Open, your machine opens the saved map. 

o If you choose Save, Netspan displays a confirmation message stating that the file has 
been downloaded. 

Figure 61: Export Confirmation Message 

 

You can choose to open the saved file or to open the folder containing the saved file. For 
detailed description about how to import the map view, see Importing KML or KMZ Files. 

3.11.9 Editing Global Map Configuration 

Netspan allows you to edit the configuration of the map. To edit the map configuration, at the top right 
corner of the Node Map page, click the Global Map Configuration icon ( ). 

Figure 62: Editing Map Configuration 

 

For instructions on editing the configuration of the map and importing KML or KMZ files, see Configuring 
Map and Importing KML or KMZ Files, respectively. 

3.11.9.1 Configuring Map 

Netspan supports the following third party map tools: 

 Open Street Maps: Open Street Maps is a freeware; it does not require a license. By default, 

Open Street Maps is enabled. Click the  icon on the map to see the OpenStreetMap 
Copyright and Licence details. 

 Bing Maps: To enable the use of Bing Maps, purchase a licence from Microsoft. 

https://www.openstreetmap.org/copyright
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1. On the Netspan main menu, select Server > Map Configuration. The Edit Map 
Configuration page appears. 

Figure 63: Editing Map Configuration 

 

2. In the Map Configuration panel, check to enable the Bing Maps option, and then enter 
the licence key. 

Figure 64: Selecting Bing Maps 

 

3. Click Save to complete the procedure. 
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3.11.9.2 Importing KML or KMZ Files 

Netspan supports .kml and .kmz file import and export. This feature allows customers to import and 
export the map information to and from the external map tools. 

To restrict the map to display locations of interest, you can create and import a customized KML or KMZ 
file. 

To import KML or KMZ files: 

1. On the Netspan main menu, select Server > Map Configuration. The Edit Map Configuration 
page appears. 

Figure 65: Edit Map Configuration Page 

 

2. In the KML Layers panel, click Add. 

Figure 66: Adding a KML or KMZ File 
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The Add KML or KMZ page appears. 

Figure 67: Adding KML/KMZ 

 

3. Browse to the KML or KMZ file. Specify a name for the file and add a short description. 

4. Click Upload to complete the procedure. 

Figure 68: Importing a KML or KMZ File (Example) 
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3.11.10  Adjusting Transparency 

To adjust the transparency of the map, nodes, and alarms: 

1. At the top right corner of the Node Map page, click the Dialog Map Configuration button. 

Figure 69: Accessing Map Configuration 

 

The Map Configuration pop-up window appears. 

Figure 70: Map Configuration Window 

 

2. From the Map drop-down list, select the map whose opacity you want to adjust. Table 13 lists 
the details of the available maps. 

Figure 71: Setting Opacity 
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Table 13. Available Maps 

Map Type Description Example 

Open Street 
Map 

A map of the world that is free to use under 
an open licence 

 

Bing Road 
Map 

This map displays road imagery. 

 

Bing Aerial 
Map 

This map displays aerial imagery 

 

Bing Hybrid 
Map 

This map combines the advantages of Bing 
Road Map and Bing Aerial Map. 

 

3. After selecting the map, use the slider to set the preferred opacity for the map, links, and nodes. 

Note: The opacity of the map, links, and nodes can be set to a value between 0 and 10. 

4. Click Save to apply the changes, and then click Close ( ). 

3.11.11  Reloading the Node Map 

To reload your map, click the Reload button at the top right corner of the Node Map page. 

When you refresh the node map, it retrieves information on the latest changes in your network (if any) 
and refreshes your view to include those variations. 
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Figure 72: Reloading the Node Map 
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4 Provisioning 

Provisioning is the process for setting the configuration parameters of a service profile, node profile, or 
node to enable it to operate. 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

Before a node can be provisioned, it first needs to be commissioned. This means it has its IP address, 
port number, and other details defined so that it can be discovered by Netspan and added to the 
network. This process is covered in How to Enable Discovery on a Node. Once a node has been 
commissioned it is available to be discovered by Netspan as described in How to Discover a Node in 
Netspan.  

Note: This discovery process is not applicable to PnP nodes. 

Once a node has been discovered and is available in your system, use the Netspan UI to provision the 
node ready for operation. 

Figure 73: Provisioning Process 

You can provision the nodes individually, by group or globally, where you define a single set of 
parameters and these are subsequently applied to any discovered node. 

Note: Global provisioning is not applicable to iBridge, iRelay, or eNodeB nodes. As such, it is not 

covered in this document. 
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As well as using the UI to provision nodes, it is also possible to use the NBIF to send a set of parameters 
in an XML file over a SOAP interface to be applied to the node population. This provisioning method is 
not described here, as this document focuses on the operations you perform using the Netspan UI. For 
more details on the NBIF process, see SYN-PSD-0027 Netspan NBIF Guide. 

This section describes how to: 

 How to Provision Node Profiles 

 How to Provision a Node 

 Plug & Play Configuration Import 

 How to Manage LTE Neighbour List 

 Profile Management 

4.1 How to Provision Node Profiles 

A node profile is a set of parameters, which collectively forms a profile, available in Netspan for future 
selection to apply to a node such as: a group of parameters related to radio links, synchronization 
technology, security, etc. 

The use of profiles increases the efficiency of node provisioning by enabling the selection of a set of 
pre-defined parameters rather than having to define each parameter individually, while minimizing the 
chances of having errors. 

You need to define profiles to enable full configuration of a node. When a node is added or edited, it 
needs to have a variety of profiles selected from drop-down lists. The exact range of profiles that need 
to be defined depends on the nature of the node, i.e. whether it is eNodeB, iBridge, or iRelay. All these 
node types need to have profiles already defined in the system for selection when required. Table 14 
provides a list of different profiles that need to be defined for each node type. 

Table 14. Required Profiles by Node Type 

Node Type Profiles Required 

eNodeB 

 eNodeB Global 
Configuration 

 System Default 

 eNB Advanced 
Configuration 
Profiles 

 Fault Management 
Profiles 

 Management Profiles 

 Multi-Cell Profiles 

 Neighbour 
Management Profiles 

 Network Profiles 

 Security Profiles 

 SON Profiles 

 Synchronization Profiles 

 Call Trace Profiles 

 Cell Advanced Configuration Profiles 

 eMBMS Profiles 

 Mobility Profiles 

 Radio Profiles 

 Traffic Management Profiles 

 

iBridge2 

 Global Configuration 

 Base Management 
Profile 

 Term Management 
Profile 

 Alarm Profile 

 QoS Profile 
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Node Type Profiles Required 

iBridge 

 Base System Default 

 Base Management 
Profile 

 Base Radio Profile 

 Term System Default 

 Term Radio Profile 

Relay 

 Relay Global 
Configuration 

 Relay System 
Default 

 Relay Profile 

 Relay Advanced Profile 

iBridge 440  QoS Profile  

All node profiles should be defined before you begin the process of using them to provision a node. The 
Netspan process flow is not designed to enable you to jump away from the node provisioning task to 
create or edit profiles in the middle of the process. 

To provision a node profile: 

1. On the main Netspan menu, choose Node Profiles to expand the list of available node types. 
Each of these node types has its own set of profiles. Select the node type you require to expand 
the profile menu options and click on the profile type you want to provision. For example, 
iBridge > Base System Default or eNodeB > Management Profiles. 

Figure 74: iBridge Base System Default Profiles Screen 

 

2. This opens the Profiles screen, for the profile type you have selected, which displays a list of 
profiles already defined in your system. 

3. To add a new profile, click Add at the bottom of the screen. This opens the Profile screen for 
your new profile. For more details on the parameters and description on each field, refer ARD-
D00741 Netspan Parameters Reference Guide. The Reference Guide document describes all 
eNodeB and iBridge profile parameters you need to enter. 

Figure 75: Add iBridge Base System Default Profile Screen 

 

4. When you have finished creating your profile, click OK to commit your profile and return to the 
profiles list screen. Your new profile will be added to the list. 
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5. If you want to edit an existing profile rather than creating a new one, click on the required profile 
in the list and click Edit. This opens the profile screen for your selected profile with its 
parameters pre-populated. Change the details as required and click OK to commit your 
changes and return to the list of configured profiles. 

Note: Bear in mind that while it is possible for you to edit an existing node profile, it may 

already be active on many nodes, so any changes should be made with extreme caution. 

6. With your profile created or edited, it will be now available for selection during the node 

provisioning process. 

4.2 How to Provision a Node 

A node can only be provisioned once it has been discovered in the network, meaning it is visible to 
Netspan. In order to discover nodes, see How to Discover a Node in Netspan. With the required node 
discovered, you are then able to provision it to enable it for service. 

To provision a node: 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of nodes currently available in your system. 

Figure 76: Node List Screen 

 

2. Click on the node you want to provision and click Manage. This displays the Provision screen 
populated with the current details of your selected node. 
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Figure 77: Edit Node Screen  

 

3. Change these details as required, refer ARD-D00741 Netspan Parameters Reference Guide to 
provide you with the information you need to complete the relevant fields.  

Note: The exact array of fields you will see and need to complete will vary depending on 
the type of the node you are provisioning. 

Netspan automatically applies appropriate filters to ensure that only node profiles applicable 
to your selected node type are available for selection on your node. For example, if you are 
provisioning an iBridge 460 node, you will only be able to choose from management profiles 
that are appropriate to iBridge 460. 

4. Once you have completed the details you need, click OK to commit your changes and return to 
the Node List screen. Your newly provisioned node will now be shown in the list. 

4.3 How to Provision a Plug & Play Node 

A plug-and-play node is the one that is automatically added to the network. Netspan automatically 
discovers it and applies a pre-defined set of provisioning parameters to make it ready for operation, 
without the need for you to discover and provision the node manually through the Netspan UI. 

Note: This section is applicable to eNodeB, iBridge2, iBridge NLOS, and iRelay only. 

This is a different provisioning method from the manual process described in How to Provision a Node. 
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To provision a plug & play node: 

1. On the main Netspan menu, choose Configuration Management > PnP > PnP 
Configuration. The Plug And Play Configuration List screen will be displayed with a list of 
plug and play configurations that are currently available in your system. 

Figure 78: Plug and Play Configuration List Screen 

 

2. Click Add to create a configuration profile for a new node. The Add PnP Configuration screen 
will be displayed. 

Figure 79: Add PnP Configuration Screen 

 

3. You can create PnP configuration profiles for the node types: eNodeB, iBridge 2, iBridge 
Base, iBridge Term, and Relay. Each node type has a button at the top of the screen. Click 
the one relevant to the node you are adding a profile to display appropriate fields. 
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Note: The parameters you need to define for each node type are not described in detail in 
this document. Instead, refer ARD-D00741 Netspan Parameters Reference Guide for a 
comprehensive explanation of the parameters you need to set and what you should enter in 
each field per node type. 

4. In addition to the usual node parameters, the PnP Configuration screen also features a Plug 
and Play Properties panel, which contains the parameters you need to define to enable the 
plug and play discovery and provisioning process to take place. This Plug and Play Properties 
panel is common across all three node types. 

Figure 80: Plug and Play Properties Panel 

 

Enter values in each of these fields according to the descriptions in Table 15. 

Table 15. Plug and Play Properties Parameters 

Field Description 

Hardware Type 

A drop-down list of the available hardware types for your node. The content 
of this list will vary depending on whether you are setting configuration for 
eNodeB, iBridge Base, iBridge Term, or iRelay node. Choose the hardware 
type applicable to your node. This is a mandatory field. 

Hardware ID (SN) 

At this stage, the node’s IP address is not known to Netspan. Instead, node 
identification and discovery is based on the hardware ID. This is pre-
configured on the node, so your entry here needs to match the hardware ID 
on the node. This is a mandatory field. 

Service State Allows you to configure the initial node operational status. 

Use Location 
Use location allows user to enter a location where the node is expected. 
When the checkbox is enabled, it provides Latitude Longitude of the 
expected location of the node. 

Mode 
This parameter is used to select Use Location modes for movement 
detection. 

Latitude 

Along with Longitude, this specifies the expected physical location of the 

node. This ensures that when the node is discovered, it is in the correct 
location and has not been moved outside the radius. This field is optional. 

Longitude 

Along with Latitude, this specifies the expected physical location of the 

node. This ensures that when the node is discovered, it is in the correct 
location and has not been moved outside the radius. This field is optional. 

Latitude – Longitude 
Radius (m) 

Enter a value, in meters, to allow for an element of variation from the latitude 
and longitude settings you specified for the node’s location. This means that 
as long as the node is within the defined distance away from the specified 
location, it is still discovered without problems. This field is optional. 
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Field Description 

Software Image 

There is no software preconfigured on the node, so you need to specify the 
software image to download on the node to make it operational once it has 
been discovered. The content of the list will vary depending on the type of 
the node you are defining. This field is optional. 

Schedule This parameter is available only if a Software image is selected. 

5. There are some aspects to the configuration of different node types that you should be aware 
of beyond the parameter descriptions provided in the Netspan Parameters Reference Guide. 

6. iBridge bases and terminals are all manufactured as terminals. A base always has a physical 
wire connection, while a terminal is wireless. When Netspan receives an SNMP trap from a 
wired iBridge node, it knows to apply the base profile. When a trap is received from a wireless 
node, the terminal profile is applied. 

7. When you have completed your PnP configuration, click OK. You will be returned to the Plug 
and Play Configuration List screen and your new configuration profile will now appear in the 
list. 

4.4 Plug & Play Configuration Import 

Netspan provides a mechanism to allow PnP bulk configuration (i.e. to import multiple eNodeB 
configurations into Netspan over its NBIF) using a bulk file. 

Figure 81 shows Netspan accepting inputs from customer’s provisioning tool. 

Figure 81: PnP Bulk Configuration Implementation 
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4.4.1 Bulk Configuration Access 

Netspan creates a bulk configuration import module, which runs within Netspan. You can open or 
access this module using the Bulk Import button. 

To access the Plug and Play Configuration List page: 

1. Log in to Netspan. 

2. On the Netspan main menu, select Configuration Management > PnP > PnP Configuration. 
The Plug and Play Configuration List page appears. 

Figure 82: Plug and Play Configuration 

 

4.4.2 Bulk Configuration Module Options 

To access the Bulk Configuration module options: 

1. On the Plug and Play Configuration List page, click the Bulk Import button. The Import 
Plug and Play Bulk Configurations page appears. Alternatively, you can select 
Configuration Management > PnP > PnP Configuration Bulk Import. 

Figure 83: Selecting Bulk Import 

 

2. On the Import Plug and Play Bulk Configurations page, select the required option: 

o Add/Edit: Use this option to add nodes to the Netspan PnP node list or to update the 
parameters configured in a node within the PnP node list. 

o Validate: Use this option to validate the imported bulk configuration file intended for node 
addition, modification, or deletion. 

o Delete: Use this option to delete nodes from the PnP node list. 

o Choose File: Use this option to browse the file for batch configuration. 

o Download To Log File: Use this option to download the output log to a file. 

o Clear Log: Use this option to clear the log information. 
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Figure 84: Bulk Configuration Options 

 

4.5 How to Manage LTE Neighbour List 

Netspan provides a method to provision neighbours for Airspan eNodeBs. The neighbours can be any 
of the following: 

 Airspan eNodeB 

 3rd party eNodeB 

4.5.1 How to Manage a 3rd Party eNodeB 

When adding neighbours for an Airspan eNodeB, you can also add 3rd party eNodeBs. However, prior 
to adding a 3rd party eNodeB as a neighbour, for Netspan to identify that eNodeB, you must add its 
details. 

This section includes procedures for the following: 

 Adding a 3rd Party eNodeB 

 Cloning a 3rd Party eNodeB 

 Editing Details of a 3rd Party eNodeB 

 Deleting a 3rd Party eNodeB 

 Moving a 3rd Party eNodeB Configured on Node to Netspan 3rd Party eNodeB List 

4.5.1.1 Adding a 3rd Party eNodeB 

To add a 3rd party eNodeB: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party eNodeB. 
The 3rd Party eNodeB page will be displayed. 

Figure 85: 3rd Party eNodeB List 

 

2. Click Add. The Add 3rd Party eNodeB page will be displayed. 
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3. In the eNB Properties panel enter the details of the eNodeB that you want to add, and then 
click on Save. 

Figure 86: Adding a 3rd Party eNodeB 

 

Table 16 lists the properties that you need to specify when adding a new 3rd party eNodeB. 

Table 16. 3rd Party eNodeB Properties 

Property Description Data Type Range 

Name 
A user-friendly name 
for the 3rd party 
eNodeB. 

String 
2 to 64 characters 
(excluding ‘<’ and ‘&’) 

IP Address 
The IP address of 3rd 
party eNodeB’s X2 
control plane. 

String 
IPv4, 

IPv6 

Physical Layer Cell 
Group 

The Physical Layer Cell 
Group of the 3rd party 
eNodeB. 

Integer 0 to 167 

Physical Layer Identity 
The Physical Layer 
Identity of the 3rd party 
eNodeB. 

Integer 0 to 2 

Physical Cell ID 

The PCI of the 3rd 
party eNodeB. 

Note: Netspan 

automatically populates 
this value. The PCI of a 
3rd party eNodeB is 

Integer 0 to 503 
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Property Description Data Type Range 

calculated using the 
following formula: 

PCI = (Physical Layer 
Group x 3) + Physical 
Layer Identity. 

This field is read only. 

eNB Type 
The type of the 3rd 
party eNodeB. 

String 
Macro, 

Home 

eNB ID 

The 20-bit eNodeB ID 
of the 3rd party 
eNodeB. 

Note: This property 
applies to Macro 

eNodeBs only. 

Integer 0 to 1048575 

Cell ID 

The 8-bit Cell ID of the 
3rd party eNodeB. 

Note: This property 
applies to Macro 

eNodeBs only. 

Integer 0 to 255 

Tracking Area Code 
The tracking area code 
of the 3rd party 
eNodeB. 

Integer 0 to 65535 

Downlink EARFCN 
The downlink EARFCN 
of the 3rd party 
eNodeB. 

Integer 0 to 46589 

Bandwidth (MHz) 
The bandwidth of the 
3rd party eNodeB. 

Integer 
[1.4, 3, 5, 10, 15, 20] 
MHz 

Latitude () 

The latitude of the 3rd 
party eNodeB. 

Note: This is an 

optional property. 

Decimal -90 to 90 

Longitude () 

The longitude of the 3rd 
party eNodeB. 

Note: This is an 

optional property. 

Decimal -180 to 180 

Closed Subscriber Group Configuration 

Closed Subscriber 
Group Mode 

This parameter enables 
CSG Access Control 

Mode. 
Enumerated Open, Closed, Hybrid 

PLMN Configuration 

Type 
Specifies whether it is 
an MNO or an MVNO. 

String Not configurable 

MCC 
Specifies the mobile 
country code. 

Integer 0 to 999 

MNC 
Specifies the mobile 
network code. 

Integer  0 to 999 

You can find the newly added eNodeB on the 3rd Party eNB list. 
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4.5.1.2 Cloning a 3rd Party eNodeB 

The easiest way to add a new 3rd party eNodeB is to clone an existing 3rd party eNodeB and update it 
with the details of the new eNodeB that you want to add. 

To clone an existing 3rd party eNodeB: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party eNodeB. 
The 3rd Party eNodeB page will be displayed. 

Figure 87: 3rd Party eNodeB List 

 

2. From the 3rd Party eNodeB list, select the eNodeB that you want to clone and then click Clone. 

Figure 88: Selecting an Existing eNodeB 

 

3. On the Add 3rd Party eNodeB page make the required changes and then click Save. For more 
information on the 3rd Party eNodeB properties, see Table 16. 
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Figure 89: Cloning a 3rd Party eNodeB 

 

You can find the details of the newly added node on the 3rd Party eNodeB list. 

4.5.1.3 Editing Details of a 3rd Party eNodeB 

To edit the details of a 3rd party eNodeB: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party eNodeB. 
The 3rd Party eNodeB page will be displayed. 

Figure 90: 3rd Party eNodeB List 
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2. From the 3rd Party eNodeB list select the node whose details you want to update and then 
click Edit. 

Figure 91: Selecting the eNodeB 

 

3. On the Edit 3rd Party eNodeB page make the required changes and then click OK. For more 
information on the 3rd Party eNodeB properties, see Table 16. 

Figure 92: Editing the eNodeB Details 
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4.5.1.4 Deleting a 3rd Party eNodeB 

To delete a 3rd party eNodeB: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party eNodeB. 
The 3rd Party eNodeB page will be displayed. 

Figure 93: 3rd Party eNodeB List 

 

2. From the 3rd Party eNodeB list select the eNodeB that you want to delete and then click 
Delete. 

Figure 94: Selecting the eNodeB 

 

3. A confirmation message box will be displayed, asking if you want to delete the selected 
eNodeB. Click Delete. The node will then be removed from the 3rd Party eNB list. 

Figure 95: Deleting the eNodeB 
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4.5.1.5 Moving a 3rd Party eNodeB Configured on Node to Netspan 3rd 
Party eNodeB List 

You can add a 3rd party eNodeB, configured on a node, to the Netspan neighbour list and thereby to 
the 3rd party eNodeB list. You can perform this process only when ANR is set to Disabled or HO 
Measurement Based. 

To add a 3rd party eNodeB to a 3rd party eNodeB list: 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all the currently configured nodes will appear. 

2. In the Node Type drop-down box select eNodeB. An eNodeB list showing the details of all 
currently configured eNodeB will be displayed. 

Figure 96: eNodeB List 

 

3. Select the eNodeB whose neighbor configuration you want to update and then click Manage. 

Figure 97: Selecting the Node 

 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  77 

4. On the Node Management page select the Neighbour Management tab. Click Edit to enable 
the edit mode. 

Figure 98: Neighbour Management Tab 

 

On the Neighbour Status panel, if the name of a node is displayed as N/A, then it denotes that 
Netspan does not have that node on the eNodeB or 3rd Party eNodeB list. To add this node to 
the 3rd Party eNodeB list, perform steps 5 through 8. 

5. When this check box is selected, an add ( ) button and a delete ( ) button will appear adjacent 
to each node name that is present in the node neighbor list (that is, on the Neighbour Status 
panel) unless it is already listed on the Neighbour Configuration panel. 
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Figure 99: Unknown Nodes 

 

6. Click add ( ) to move the required N/A node from the Neighbour Status panel to the 
Neighbour Configuration panel. 

Figure 100: Neighbour Status Panel - Moving a Node to the Netspan Neighbour List 
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This action will move the node you tried to add to Neighbour Configuration panel. 

Figure 101: Moving a Node to the Neighbour Configuration Panel (Example) 

 

7. Click Save to apply the change. Netspan will retrieve the details from the node and add this 3rd 
Party eNodeB to the 3rd Party eNodeB list. 

Figure 102: Adding a 3rd Party eNodeB (Example) 
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8. To view the 3rd Party eNodeB list, select Configuration Management > Node > 3rd Party 
eNB on the main Netspan menu. Now you can find the details of the newly added 3rd party 
eNodeB here.  

Note: This screenshot below is just an example. A similar screen will be displayed after the 
node is added in the 3rd Party eNodeB list. 

Figure 103: 3rd Party eNodeB List (Example) 

 

4.5.2 How to Manage a 3rd Party UTRAN Cell 

This section includes procedures for the following:  

 Adding a 3rd Party UTRAN Cell Node  

 Cloning a 3rd Party UTRAN Cell 

 Editing Details of a 3rd Party UTRAN Cell Node 

 Deleting a 3rd Party UTRAN Cell Node 

4.5.2.1 Adding a 3rd Party UTRAN Cell Node 

To add a 3rd Party UTRAN Cell Node: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party UTRAN 
Cell. The 3rd Party UTRAN Cell page will be displayed. Click Add, the Add 3rd Party UTRAN 
Cell page will be displayed. 

Figure 104: 3rd Party UTRAN Cell List 
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2. In the UTRAN Cell Properties panel enter the details of the node that you want to add, and 
then click on Save. 

Figure 105: Adding a 3rd Party UTRAN Cell Node 

 

Table 17. 3rd Party UTRAN Cell Properties 

Property Description Data Type Range 

Name Node Name. String 

2 to 64 unicode 
characters (excluding 
‘<’, ‘&’, and leading or 
trailing spaces) 

Primary Scrambling 
Code 

Physical cell identity for 
UMTS (3G) cells. 

Integer 0 to 511 

UARFCN 
UMTS (3G) frequency 
descriptor. 

Integer 0 to 16383 

Duplex Mode 

Duplex mode indicator. 
In UMTS releases, 
there is a different PCI 
range and 
measurement related 
encoding for FDD & 
TDD cells. 

Enumerated FDD, TDD 

RNC ID 

Identity of the 3G Radio 
network subsystem. 12 
MSBs of Global 
UTRAN cell identity 
(manually, up to 16 bit 
value may be 
configured e.g. 
Extended RNC ID) 

Integer 0 to 65535 

Cell ID 
Full cell identity as 
measured by the UE 
when fetching CGI. 

Bit String (28) 0 to 268435455 

Location Area Code 
A fixed length code 
identifying the location 
area within a PLMN. 

Bit String (16) 0 to 65535 
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Property Description Data Type Range 

Routing Area Code 

The RAC identity read 
from broadcast 
information - not 
mandatory. 

Bit String (8) 0 to 255 

Closed Subscriber Group Configuration 

Closed Subscriber 
Group Mode 

This parameter enables 
CSG Access Control 
Mode. 

Enumerated Enabled, Disabled 

Closed Subscriber 
Group ID 

Unique identifier within 
the scope of the PLMN 
which identifies a 
Closed Subscriber 
Group in the PLMN. 

Integer 0 to 134217727 

PLMN Configuration 

MCC 
Specifies the mobile 
country code. 

Integer 0 to 999 

MNC 
Specifies the mobile 
network code. 

Integer  0 to 999 

4.5.2.2 Cloning a 3rd Party UTRAN Cell 

The easiest way to add a new 3rd Party UTRAN Cell node is to clone an existing 3rd party eNodeB and 
update it with the details of the new node that you want to add. 

To clone an existing 3rd Party UTRAN Cell node: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party UTRAN 
Cell. The 3rd Party UTRAN Cell page will be displayed. Select the node that you want to clone 
and then click Clone. 

Figure 106: 3rd Party UTRAN Cell List 
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2. On the Add 3rd Party UTRAN Cell page make the required changes and then click Save.  

Figure 107: Cloning a 3rd Party UTRAN Cell Node 

 

4.5.2.3 Editing Details of a 3rd Party UTRAN Cell Node 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party UTRAN 
Cell. The 3rd Party UTRAN Cell page will be displayed. Select the node whose details you 
want to update and then click Edit. 

Figure 108: 3rd Party UTRAN Cell List 

 

2. On the Edit 3rd Party UTRAN Cell node page make the required changes and then click Save. 

Figure 109: Editing 3rd Party UTRAN Cell Node Details 
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4.5.2.4 Deleting a 3rd Party UTRAN Cell Node 

To delete a 3rd Party UTRAN Cell Node: 

1. On the Netspan main menu, select Configuration Management > Node > 3rd Party UTRAN 
Cell. The 3rd Party UTRAN Cell page will be displayed. Select the node which you want to 
delete and then click Delete. 

Figure 110: 3rd Party UTRAN Cell List 

 

2. A confirmation message box will be displayed, asking if you want to delete the selected 
eNodeB. Click Delete. The node will then be removed from the 3rd Party UTRAN Cell Node 
list. 

Figure 111: Deleting 3rd Party UTRAN Cell Node 

 

4.5.3 How to Manage Neighbours 

Note: This section applies to 3rd party and Airspan eNodeBs only. 

4.5.4 Configuring ANR on SON Profile 

While provisioning a SON profile, you can set ANR to one of the following states: 

 Disabled 

 HO Measurement Based 

 Periodical Measurement Based 

Figure 112: ANR Options 
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For more information on how to provision a node profile, see How to Provision Node Profiles. 

You can manually configure neighbours through Netspan only when ANR is set to Disabled or HO 
Measurement Based. For instructions on how to manually configure a neighbour using Netspan, see 
How to Add a Static (White - Listed) Neighbour and How to Add a Non-Static Neighbour. 

Note: You cannot manually configure neighbours through Netspan when ANR is set to Periodical 
Measurement Based. 

Figure 113: ANR State: Periodical Measurement Based 

 

4.5.4.1.1 How to Add a Static (White - Listed) Neighbour 

Note: You can add neighbours for an eNodeB only if that eNodeB has ANR Disabled or HO 
Measurement Based SON profile. 

To add static neighbours: 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all currently configured nodes will appear. In the Node Type drop-down 
box select eNodeB. An eNodeB list showing the details of all currently configured eNodeB will 
be displayed. 

Figure 114: eNodeB List 
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2. Select the eNodeB for which you want to add neighbours and then click Manage. 

Figure 115: Selecting the Node 

 

3. On the Node Management page select the Neighbour Management tab. 

Figure 116: Neighbour Management Tab 

 

The Neighbour Management tab includes the following panels: 

o Node Configuration - allows you to configure Auto X2 Control, X2 Configuration Update, 
and Default X2 Control State. 

Note: Default X2 Control State is used as default X2 Control State for any new 
neighbours added manually. 

o Neighbour Configuration (x) - where x denotes the number of eNodeBs configured as 
neighbours for the selected node in Netspan. 

Note: This panel does not appear when ANR is set to Periodical Measurement 
Based. 

o Neighbour Status (x) - where x denotes the number of eNodeBs configured as 
neighbours (for the selected node) on the equipment. Netspan automatically refreshes 
the list of neighbour nodes periodically. 
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For more information on the parameters that you view under each panel see ARD-D00741 
Netspan Parameters Reference Guide. 

4. Click Edit to enable the edit mode. 

Note: This check box does not appear when ANR is set to Periodical Measurement 
Based. 

Figure 117: Allowing Edit 

 

5. In the Neighbour Configuration panel, to add neighbours, do one of the following: 

o Search for specific neighbours by adding their names: 

a. Add the name of the node that you want to add to the By Name box and then click 
( ) to list it on the Neighbours list. 

Figure 118: Adding a Neighbour by Name 

 

o Search for neighbours by distance: 

a. Select the By Distance check box. Then, Netspan displays a drop-down list 
containing the names of all the neighbour nodes. 

b. From the By Distance drop-down list, select the node that you want to add as a 
neighbour, and then click ( ) to list it on the Neighbours list. 
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Figure 119: Adding a Neighbour by Distance 

 

6. Once you have completed the process of adding a neighbour manually, you can find the details 
of that neighbour on the Neighbour Configuration panel. 

Figure 120: Adding a Neighbour 

 

Figure 121: Updated Neighbour List (Example) 

 

By default, all the manually added neighbours are static neighbours. For a manually added 
neighbour, you can find that the Static Neighbour check box is automatically selected. 

7. Click OK. 

4.5.4.1.2 How to Add a Non-Static Neighbour 

Note: You can add neighbours for an eNodeB only if that eNodeB has an ANR Disabled or HO 
Measurement Based SON profile. 

1. Perform steps 1 through 6 listed in How to Add a Static (White - Listed) Neighbour. 

2. Once you have completed the process of adding a neighbour manually, you can find the details 
of that neighbour on the Neighbours panel. 

Figure 122: Neighbour Details (Example) 

 

By default, all the manually added neighbours are static neighbours. To change the state of a 
neighbour eNodeB from static to non-static, deselect the Static Neighbour check box. 
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Figure 123: Non-Static Neighbour (Example) 

 

3. Click OK. 

Note: ANR might remove a non-static neighbour during its operation. 

4.5.5 How to View Neighbour List 

Note: This section applies to 3rd party and Airspan eNodeBs only. 

This section includes procedures for the following: 

 Viewing Neighbour List 

 How to Delete a Neighbour from Netspan Neighbour List 

 How to Move a Neighbour Configured on Node to Netspan Neighbour List 

 How to Delete a Neighbour Configured on Node 

4.5.5.1 Viewing Neighbour List 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all currently configured nodes will appear. In the Node Type drop-down 
box select eNodeB. An eNodeB list showing the details of all currently configured eNodeB will 
be displayed. 

Figure 124: eNodeB List 
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2. Select the eNodeB whose neighbours you want to view, and then click Manage. 

Figure 125: Selecting a Node 

 

3. On the Node Management page, you can view the list of neighbours on the Neighbour 
Configuration panel. 

Figure 126: Neighbour List 

 

4. After reviewing the details click Close to return to the eNodeB List screen. 
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4.5.5.2 How to Delete a Neighbour from Netspan Neighbour List 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all currently configured nodes will appear. In the Node Type drop-down 
box select eNodeB. An eNodeB list showing the details of all currently configured eNodeB will 
be displayed. 

Figure 127: eNodeB List 

 

2. Select the eNodeB whose neighbour you want to delete and then click Manage. 

Figure 128: Selecting a Node 

 

3. Click Edit to enable the edit mode. When you click the Edit button, a Delete All button appears 
on the Neighbour Configuration panel. 

o To delete all nodes listed in the Netspan neighbour list: 

a. Click the Delete All button to mark all nodes for deletion.  

b. Click Save to confirm deletion. 
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Figure 129: Deleting All Neighbour Nodes 

 

o To delete specific nodes, click ( ). Then click Save to confirm the node marked for 
deletion.  

Figure 130: Deleting Specific Neighbour Nodes 

 

The selected nodes will be removed from the list. 

4.5.5.3 How to Move a Neighbour Configured on Node to Netspan 
Neighbour List 

Neighbours configured on the nodes, but not added to the neighbour list of Netspan, appear on the 
Node Status panel. On certain occasions, you might need to update the details of a neighbour 
configured on the node. In such cases, first you need to move them to the Netspan neighbour list, and 
then make the required changes. 

To move a node to the Netspan neighbour list: 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all currently configured nodes will appear. In the Node Type drop-down 
box select eNodeB. An eNodeB list showing the details of all currently configured eNodeB will 
be displayed. 
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Figure 131: eNodeB List 

 

2. Select the eNodeB whose neighbor configuration you want to update and then click Manage. 

Figure 132: Selecting a Node 

 

3. On the Node Management page, you can find the details of the neighbours that are configured 
on the node under the Neighbour Status panel. 

Figure 133: Neighbour Status Panel (Example) 

1.  

Note: Netspan retrieves the information shown on the Neighbour Status panel from the 
node. 

4. Click Edit to enable the edit mode. When you click Edit, an add ( ) button and a delete ( ) 
button will appear adjacent to each node name that is present in the node neighbor list (that is, 
on the Neighbour Status panel), unless it is already listed on the Neighbour Configuration 
panel. 
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5. Click add ( ) to move a node from the Neighbour Status panel to the Neighbour 
Configuration panel. 

Figure 134: Neighbour Status Panel - Moving a Node to Netspan Neighbour List (Example) 

 

6. This action will move the node you tried to add to the Neighbour Configuration panel. 

Figure 135: Moving a Node to Neighbour Configuration Panel (Example) 

 

7. Click Save to apply the change. 
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4.5.5.4 How to Delete a Neighbour Configured on Node 

If you want to remove a neighbour node that is configured on the node but not added to the Netspan 
Neighbour list, perform the following. 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of the currently configured nodes will appear. In the Node Type drop-down 
box select eNodeB. An eNodeB list showing the details of all currently configured eNodeB will 
be displayed. 

Figure 136: eNodeB List 

 

2. Select the eNodeB whose neighbour you want to delete and then click Manage. 

Figure 137: Selecting a Node 

 

3. On the Neighbour Management tab, you can find the details of the neighbours that are 
configured on the node under the Neighbour Status panel. 

Figure 138: Neighbour Status Panel - Neighbour Nodes Configured on a Node (Example) 
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Note: Netspan retrieves the information shown on the Neighbour Status panel from the 
node. 

4. Click Edit to enable the edit mode. When you click Edit, an add ( ) button and a delete ( ) 
button will appear adjacent to each node name that is present in the node neighbor list (that is 
on the Neighbour Status panel), unless it is already listed on the Neighbour Configuration 
panel. To delete a node from the list, click the delete ( ) button. 

Figure 139: Deleting a Node - Neighbour Status Panel (Example) 

 

5. This action will move the node you tried to delete from Neighbour Configuration panel and 
mark it for deletion. 

Figure 140: Marking a Node for Deletion (Example) 
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6. Click Save to confirm deletion. 

4.5.6 How to Blacklist a Neighbour 

Note: This section applies to 3rd party and Airspan eNodeBs only. 

Depending on the uplink and downlink signal quality and the measurement result from a UE, an eNodeB 
might initiate handing over of UEs to other eNodeBs in the Neighbours list. Blacklisting is the process 
of preventing a source eNodeB from handing over its UEs to specific neighbour eNodeBs. 

On some occasions (for example, when you want to use an eNodeB exclusively for specific UEs) you 
will have to prevent an eNodeB from handing over its UEs to specific neighbour eNodeBs. You can 
accomplish this by blacklisting the neighbour eNodeBs to which you do not want a source eNodeB to 
handover its UEs. 

To blacklist a neighbour: 

1. On the Netspan main menu, select Configuration Management > Node > Node. A node list 
showing the details of all currently configured nodes appears. In the Node Type drop-down box 
select eNodeB. An eNodeB list showing the details of all currently configured eNodeBs 
appears. 

Figure 141: eNodeB List 

 

2. Select the eNodeB whose neighbour you want to blacklist, and then click Manage. 

Figure 142: Selecting a Node 
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3. Select the Allow Edit check box to enable the edit mode. 

Figure 143: Allowing Edit 

 

4. On the Neighbour Management tab, under Neighbour Status panel, click ( ) to edit the 
neighbour that you want to blacklist. Then, under Dynamic Pending Changes, set Ho Control 
State to Prohibited and X2 Control State to Not Allowed for the neighbour that you want to 
blacklist. 

Figure 144: Blacklisting a Neighbour 

 

5. Click Save to apply the change. 

Note: To retain a neighbour in the blacklisted state and to prevent ANR from unlearning 
the properties of that neighbor, during the process of blacklisting a neighbour, you must 
select the Static Neighbour check box. 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  99 

4.5.7 PnP Node Match 

If the hardware ID is not configured and multiple nodes match a location in Netspan PnP configuration, 
then the user can manually select one node at a time and match it with an appropriate PnP 
configuration. 

1. On the Netspan main menu, select Configuration Management > PnP > PnP Node Match. 

Figure 145: PnP Node Match 

 

2. Select a node from the drop-down option. 

Figure 146: Node selection 

 

3. A screen will be displayed with details about the selected node. Once the user has selected the 
mismatched Hardware ID, a list of matching PnP configuration will be displayed and the user 
can select the desired PnP configuration and insert the Hardware ID using the ‘Update 
Hardware ID’ option.  

Figure 147: PnP Node Match details 

 

4.6 Profile Management 

The two eNodeB profiles: eNB Advanced Configuration Profile and Cell Advanced Configuration Profile, 
provide you with the option to select explicit and implicit values for the parameters. The function of these 
buttons is explained below. 

Figure 148: Explicit/Implicit Buttons 
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Explicit Default Values 

This button coverts all the unticked properties to ticked properties and displays the Netspan default 
values. The user can set a new value to this property, if required. An exclamation mark will be displayed 
if this default value changes. Once you click on the OK button, the values of all the properties will be 
saved for the selected profile and will be retained even after Netspan Upgrade. An exclamation mark 
will be displayed, if the default value changes after Netspan Upgrade. 

Implicit Default Values 

This button converts all the ticked properties to unticked properties only if their value equals to the 
default value. The properties, whose default values have changed after Netspan upgrade, will remain 
ticked and an exclamation mark will be displayed, indicating the default value set in Netspan.  

4.7 Re-allocating PCI 

On certain occasions, for example, when there is a PCI violation or conflict, you might need to invoke 
the Auto-PCI algorithm manually to re-allocate the PCI of the cells of a node. 

Netspan allows users to manually perform PCI re-allocation on Auto-PCI enabled nodes. You may 
choose to re-allocate the PCI of a specific cell or all cells on the selected node. Netspan displays the 
status of the PCI re-allocation. 

Note: To perform the procedure detailed in this section, the node that you select for re-allocating the 
PCI must be online. 

To re-allocate the PCI of the cells of a node, do the following (in the given order): 

1. Verifying the Auto-PCI Configuration 

2. Re-allocating the PCI 

4.7.1 Verifying the Auto-PCI Configuration 

Note: You can manually re-allocate PCI of the cells of an Auto-PCI enabled node. 

To verify if Auto PCI is enabled in the SON profile: 

1. On the Netspan main menu, select Configuration Management > Node > Node. The All 
Nodes List appears. 

2. Select the node that requires a change in cell PCI, and then click Edit. 

Figure 149: All Nodes List – Selecting the Node 
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3. Click the Edit the Selected SON Profile button in the eNodeB Properties panel. 

Figure 150: Opening the SON Profile of the Selected Node 

 

4. Confirm that Auto PCI is enabled and the related parameters are configured appropriately in 
the SON profile. For more information on these parameters, see the Netspan Parameters 
Reference Guide (ARD-D00741). 

Figure 151: Verifying the Auto PCI Configuration 
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4.7.2 Re-allocating the PCI 

To manually re-allocate the PCI of the cells of an Auto-PCI enabled node: 

1. On the Netspan main menu, select Configuration Management > Node > Node. The All 
Nodes List appears. 

2. Select the node whose cell PCI you want to change, and then click Manage. 

Figure 152: All Nodes List – Selecting the Node 

 

3. Select the Status tab, and then from the Status Type drop-down list, select SON Status. 

4. Click the Reallocate PCI button in the Action column of the cell that requires a change in PCI. 

Figure 153: Status Tab – SON Status 
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5. In the succeeding Confirmation Request window: 

o Click the Reallocate Cell Number button if you only want to re-allocate that cell’s PCI. 

o Click the Reallocate All button if you want to re-allocate the PCI of all cells of that node. 

Figure 154: Confirmation Request – Re-allocating the Cell PCI 

 

After trying to allocate a new PCI to the cells, Netspan reports the PCI re-allocation status in 

the Reallocation Info field indicating whether your attempt was successful or not. The PCI 

Status field of each cell reports the status of your most recent attempt. 

Figure 155: PCI Re-allocation Status 
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5 Configuration Management 

This sections describes: 

 Topology 

 File Servers 

5.1 Topology 

5.1.1 Regions 

1. On the Netspan main menu, select Configuration Management > Topology > Regions. The 
Regions page will be displayed.  

Figure 156: Regions 

 

5.1.1.1 Add Regions 

1. On the Netspan main menu, select Configuration Management > Topology > Regions. The 
Regions page will be displayed. Click Add to add new region. 

Figure 157: Adding Region 
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2. Enter the Name and Description and click Save. 

Figure 158: Adding Region 

 

5.1.1.2 Editing a Region 

1. On the Netspan main menu, select Configuration Management > Topology > Regions. The 
Regions page will be displayed. Select the region you want to edit and click Edit. 

Figure 159: Editing Region 

 

2. Make the necessary changes and click OK. 

Figure 160: Editing a Region 

 

5.1.1.3 Exporting Regions 

1. Click Export to export just the Regions you can currently see. Your browser will show a 
message asking if you want to open or save Export.csv the Excel file generated by Netspan for 
export. Click Open or Save as appropriate. 

Figure 161: Export Excel File Message 
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2. If you choose Open, your machine will launch an Excel file and will display the exported file 
with details. 

Figure 162: Excel File View 

 

3. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 163: Export Confirmation Message 

 

5.1.1.4 Reloading a Page 

Clicking the Reload button on an active page prompts Netspan to retrieve real-time information from 
the node and update data on that page. 

Note: The process for opening or saving the file is the same for Export. 

To refresh a page, click the Reload button.  

Figure 164: Page Reload Options 

 

Tip: To enable automatic reload, select 15 s, 30 s, or 60 s from the drop-down list next to the Reload 
button. 
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5.1.1.5 Deleting a Region 

1. On the Netspan main menu, select Configuration Management > Topology > Regions. The 
Regions page will be displayed. Select the region you want to delete and click Delete. 

Figure 165: Deleting a Region 

 

2. A confirmation message box will be displayed, asking if you want to delete the selected Region. 
Click Delete. The Region will then be removed from the list. 

Figure 166: Deleting a Region 

 

5.1.2 Sites 

1. On the Netspan main menu, select Configuration Management > Topology > Sites. The 
Sites page will be displayed. 

Figure 167: Sites  
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5.1.2.1 Adding Sites 

1. On the Netspan main menu, select Configuration Management > Topology > Sites. The 
Sites page will be displayed. Click Add to add a new site. 

Figure 168: Adding a Site 

 

2. Enter the necessary details and click Save. 

Figure 169: Adding Site Details 

 

Table 18. Site Details 

Field  Description 

Name 
Specifies the site name, which should contain 2 
to 64 unicode characters (excluding ‘<’, ‘&’, and 
leading or trailing spaces). 

Description 
Specifies the site description, which should 
contain 0 to 128 unicode characters (excluding 
‘<’, ‘&’, and leading or trailing spaces). 

Region Specifies the region defined in Netspan. 

Latitude 
This property is used for identifying the physical 
location of the unit. 

Longitude 
This property is used for identifying the physical 
location of the unit. 

Automatic Update of GPS Coordinates Enabled 
You can enable the automatic update of GPS 
coordinates by clicking on this checkbox.  
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5.1.2.2 Cloning a Site 

1. On the Netspan main menu, select Configuration Management > Topology > Sites. The 
Sites page will be displayed. Select the site that you want to clone and then click on Clone. 

Figure 170: Cloning a Site 

 

2. On the Add Site page enter the required details and click Save. 

Figure 171: Adding Site Details 

 

5.1.2.3 Editing a Site 

1. On the Netspan main menu, select Configuration Management > Topology > Sites. The 
Sites page will be displayed. Select the site that you want to edit and then click on Edit.  

Figure 172: Editing a Site 
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2. On the Edit Site Properties page make the changes and click Save. 

Figure 173: Editing Site Properties 

  

5.1.2.4 Exporting Sites in Excel Format 

1. Click Export All to export all the Sites held in Netspan’s database. Your browser will show a 
message asking if you want to open or save Export.csv the Excel file generated by Netspan for 
export. Click Open or Save as appropriate. 

Figure 174: Export Excel File Message 

 

2. If you choose Open, your machine will launch an Excel file and will display the exported file 
with details. 

Figure 175: Excel File View 

 

3. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 176: Export Confirmation Message 
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5.1.2.5 Reloading a Page 

Clicking the Reload button on an active page prompts Netspan to retrieve real-time information from 
the node and update data on that page. 

Note: The process for opening or saving the file is the same for Export All. 

To refresh a page, click the Reload button.  

Figure 177: Page Reload Options 

 

Tip: To enable automatic reload, select 15 s, 30 s, or 60 s from the drop-down list next to the Reload 
button. 

5.1.2.6 Deleting a Site 

1. On the Netspan main menu, select Configuration Management > Topology > Sites. The 
Sites page will be displayed. Select the site that you want to delete and then click on Delete.  

Figure 178: Deleting a Site 
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2. A confirmation message box will be displayed, asking if you want to delete the selected Site. 
Click Delete. The Site will then be removed from the list. 

Figure 179: Deleting a Site 

 

5.1.3 Tree 

1. On the Netspan main menu, select Configuration Management > Topology > Tree to view 
the Topology Navigation Tree.  

Figure 180: Topology Navigation Tree 

 

5.2 File Servers 

1. On the Netspan main menu, select Configuration Management > File Servers. A File 
Servers page will be displayed. 

Figure 181: File Servers List 
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5.2.1 Adding a File Server 

1. On the Netspan main menu, select Configuration Management > File Server. A File Servers 
page will be displayed. Click Add to add a new server. 

Figure 182: Adding a File Server 

 

2. On the Add File/Node Server page enter the necessary details and click Save. 

Figure 183: Adding File/Node Server Details 

 

5.2.2 Cloning a File Server 

1. On the Netspan main menu, select Configuration Management > File Server. A File Servers 
page will be displayed. Select the server that you want to clone and then click Clone. 

Figure 184: Cloning a Server 
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2. On the Add File/Node Server enter the details and click Save. 

Figure 185: Adding File/Node Server Details 

 

5.2.3 Editing a File Server 

1. On the Netspan main menu, select Configuration Management > File Server. A File Servers 
page will be displayed. Select the server that you want to edit and then click Edit. 

Figure 186: Editing a File Server 

 

2. On the Edit File/Node Server page enter the details and click Save. 

Figure 187: Editing a File/Node Server 
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5.2.4 Reloading a Page 

Clicking the Reload button on an active page prompts Netspan to retrieve real-time information from 
the node and update data on that page. 

Note: The process for opening or saving the file is the same for Export. 

To refresh a page, click the Reload button.  

Figure 188: Page Reload Options 

 

Tip: To enable automatic reload, select 15 s, 30 s, or 60 s from the drop-down list next to the Reload 
button. 

5.2.5 Deleting a File Server 

1. On the Netspan main menu, select Configuration Management > File Server. A File Servers 
page will be displayed. Select the server that you want to delete and then click Delete. 

Figure 189: Deleting a File Server 

  

2. A confirmation message box will be displayed, asking if you want to delete the selected File 
Server. Click Delete. The File Server will then be removed from the list. 

Figure 190: Deleting a File Server 
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6 Software Upgrade 

This section describes how to perform software upgrades across Netspan network. 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

The software installed on each node is accessed from one of the pool of software servers, all of which 
are configured and updated using Netspan. Because of this, in order to upgrade the software installed 
on the nodes in the network, it is first necessary to make the latest software available on these servers.  

The full process flow to enable you to upgrade the software on a node is illustrated below. Each step in 
this process has a corresponding sub-section in this document.  

Figure 191: Software Upgrade Process 
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This chapter covers the following topics: 

 How to Add a Software Server 

 How to Upload a Node Software Image 

 How to Delete a Node Software Image 

 How to Upgrade the Software on a Node 

 How to Upgrade Multiple Nodes per Hardware Type 

6.1 How to Add a Software Server 

Netspan provides the ability to add and manage a network of software servers on which the software 
images are stored and are then installed on the node population. This section explains the process for 
adding a new software server to Netspan. 

Note: The software server for node software does not have to reside on the Netspan server. 

To add a software server to Netspan: 

1. Login to Netspan using an account with administrator privileges. 

2. On the main Netspan menu, choose Software Management > Software Servers. The 
Software Servers screen will be displayed, showing a list of the currently configured software 
servers. 

Figure 192: Software Servers List Screen 

 

3. Click Add at the bottom of the screen. This opens the Add Software Server screen. 

Figure 193: Add Software Server Screen 
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4. In the Server Information panel, enter the details of the software server you are adding. For 
more information on the configuration parameters, see Table 19. 

Table 19. Add Software Server Configuration Parameters 

Parameter Description 

Software Server 
The name of the software server you will be adding as it is to be displayed 
in Netspan. 

Server IPv4 Address The network address of the software server you will be adding. 

Server IPv6 Address The network address of the software server you will be adding. 

Protocol Type 

The file transfer protocol type to be used by the server to provide software 
to the nodes: FTP, TFTP, or SFTP. 

Note: The protocol type TFTP does not require a User Name and 

Password to be defined and only provides minimal security. 

User Name 
The user name to log into the server. Required for protocol types of FTP 
and SFTP, hidden for TFTP. 

Password 
The password to log into the server. Required for protocol types of FTP 
and SFTP, hidden for TFTP. 

5. When you have added your details, click Test Connection to ensure that the connection to the 
software server is established successfully. A message indicating the result of the test is shown 
next to the button. 

6. Click Save to commit your changes and close the Add Software Server screen. 

6.2 How to Upload a Node Software Image 

You will need to update the software installed on the node population as features will be added and the 
software evolves. This is done by uploading a new software image to a software server which can then 
be accessed by, and installed on, the nodes. 

To upload a node software image to a software server: 

1. Login to Netspan using an account with administrator privileges. 

2. Ensure that an appropriate server is available to store your software image by choosing the 
Software Management > Software Servers menu option. The Software Servers screen will 
be displayed with a list of currently configured software servers. Check whether the server you 
need appears in this list. If not, add a server to the network using the process described in How 
to Add a Software Server. 

Figure 194: Software Servers List Screen 
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3. On the main Netspan menu, choose Software Management > Software Server Upload. The 
Upload to Software Server screen will be displayed. 

Figure 195: Upload to Software Server Screen 

 

4. Use this screen to specify the server for uploading the software image and to select an 
appropriate software image that needs to be uploaded. A full description of the fields you need 
to complete is provided in Table 20. 

Note: Where iRelay node software is a .zip archive, Netspan will extract the archive contents 
and upload these to the software server. The archive file itself will not be uploaded. 

Table 20. Upload to Software Server Configuration Parameters 

Parameter Description 

Software Server 
Choose software server for uploading the software image. A drop-
down list is provided, containing all software servers currently 
configured in your system. 

Software 

Select software image you want to upload. Click Browse to open a 

standard Windows browse dialog, which enables you to find the 
relevant file on your local machine or network that you want to upload. 

Software Server FTP File 
Path 

The file name and path as it is seen on the software server. 

5. Click Upload to execute the file upload action. 

6. Then, on the main Netspan menu, choose Software Management > Software Images. The 
Software Images screen will be displayed. Add your uploaded software to the available 
software images list so that it can be accessed by the nodes. 

7. Click Add at the bottom of the screen. This opens the Add Software Image screen. 

Figure 196: Add Software Image Screen 
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8. Use this screen to define the properties of the software image as you want them to be displayed 
on the Software Images screen. A full description of the fields you need to complete is provided 
in Table 21. 

Table 21. Add Software Image Configuration Parameters 

Parameter Description 

Name 
The software image name that is displayed when selecting the 
software from the node. 

Target Hardware Category 

A drop-down list of available hardware types configured in the system. 
Select the type of node that the software image is intended for, such 
as AirSynergy 2000. Your selection here determines which fields are 
displayed in the Properties panel as each hardware category has 

specific requirements. 

Properties 

Software Server 

Select the software server where the software image is held. 

Note: This field is not shown for target hardware category of iBridge 

440. 

Software File 

Click Browse to navigate to the software image file to upload.  

Note: This field is only shown for target hardware category of iBridge 
440. 

Image Type 

A list of available software image types in the system. Choose one 
appropriate to your software image. 

Note: This field is only shown for target hardware category of AirUnity 

and AirSpeed-Relay. 

Image File Software Server 
FTP File Path 

Automatically populated by Netspan. This is the name of the actual 
software file as loaded onto the software server in the form 
enodeb.<version>.tar.bz2. 

Note: Where iRelay node software is a ‘.zip’ archive, use the archive 
filename with ‘.manifest’ file extension in place of ‘.zip’. 

Software Version 
Automatically populated by Netspan. This is the version number of the 
software image. 

Intended Software Mode 

A drop-down list of the available modes for the software image. Select 
the one appropriate to your upload.  

Note: This field is only shown for target hardware categories of iBridge 
460. For all other categories, the field is hidden.  

9. Click Test File Exists to verify that the software image file can be identified on the server and 
that it is available for use. If this test is successful, click OK to commit the image information. 

10. When saving your software image, Netspan verifies that the version is correct. Click Yes to 
confirm and close the message. 
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6.3 How to Delete a Node Software Image 

To delete a node software image from a software server: 

1. On the main Netspan menu, choose Software Management > Software Images. The 
Software Images screen will be displayed. 

Figure 197: Software Images 

 

2. Select the Software Image that you want to delete and click Delete. 

Figure 198: Deleting a Software Image 

 

3. A Confirmation Request pop-up screen will be displayed asking for your confirmation. Click 
Delete to delete the selected software image. 

Figure 199: Deleting a Software Image 
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6.4 How to Upgrade the Software on a Node 

When a new software becomes available for a node, it needs to be uploaded to software server before 
it can be accessed (see How to Upload a Node Software Image for a description of how to do this). 
Once it is stored on a server, you can use Netspan to install the new software image on the node(s) of 
your choice. 

In a full Netspan deployment, it is likely that you would want to install the software on a single node first 
and then roll it out to multiple nodes once performance has been verified. 

To upgrade the software on a node: 

1. Login to Netspan using an account with administrator privileges. 

2. On the main Netspan menu, choose Software Management > Node Software. The Node 
Software screen will be displayed with a list of nodes currently available in Netspan along with 
their current software status. 

Figure 200: Node Software Screen 

 

3. In the Node Name column, click on the node that you want to upgrade. Click Manage at the 
bottom of the screen to display the details of that particular node on the Node Management 
screen. 

4. Select the Software tab for your chosen node. This shows details of the software that is 
currently running on the node as well as enabling you to download new software. 

Figure 201: Node Management Screen 
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5. In the Configure Software Download area click on the Allow Edit checkbox. This enables the 
fields on the screen which are otherwise read only. 

6. You can now specify the new software to install. See Table 22 for a full description of the fields 
that you need to complete. 

Table 22. Configure Software Download Parameters 

Parameter Description 

Hardware Category:Image 
Type(s) 

A read only field populated by Netspan. This shows the hardware 
category and image types that are applicable to your selected node. 

Request 

Choose your required action from the available list.  

Idle – no activity has been requested. 

Download only – the software to be activated manually at a later 

date using the Activate option is downloaded to the storage bank. 
Download and activate are kept as separate steps to control when 
service outages occur, as the process of activating a software 
change causes a service outage. Note: this option is not available if 

you are upgrading an iBridge 440 node. 

Activate (Download If Needed) – the software is downloaded to the 

storage bank and is then applied without further user intervention. 
There will be no further warnings before the node is updated with the 
new software. This is service affecting.  

Abort – cancels the currently running process. 

Software Image 
A drop-down list of applicable software images currently available in 
Netspan will be populated according to your selection in the 
Software Type field. Choose the one you want to install on the node. 

Maintenance Windows 

If selected, this option enables you to specify when you would like 
the software download to run and to be activated, by providing 
additional date, time and duration fields; see the description of the 
Run between fields for details. 

When Single is selected, Activation happens immediately after 
software download. When Both is selected, SW Download and 
Activation can be scheduled separately. 

If left clear, the download and/or activation takes place immediately. 

Between 

Only shown if Maintenance Windows is selected as Single/Both. 

Enables you to define a start time, end time, date, and duration for 
the download. This option is provided for situations where you have 
defined service windows in which you carry out network maintenance 

and upgrades. 

Allow Edit 
Clicking on this checkbox allows the user to perform software 
upgrade. 

7. Click Save to begin the software upgrade. 

8. The Current Software Status table displays information regarding the currently installed 
software on your selected node and also shows the progress of the upgrade. Netspan operates 
on a ‘dual bank’ principle, where a node can have two software versions. One that is installed 
and currently active and a second that is downloaded and ready for an upgrade. The fields in 
this table are described below. 

Note: This information is not available immediately after adding a node (unless that node is 
online). It is populated by the NMS Software Service by polling the node. 
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Table 23. Current Software Status Table Description 

Heading Description 

Image Type 
The type of the software image currently installed on the node such 
as: LTE, AirSynergy, iBridge 440, etc. 

Running Version The current software version running on the node. 

Standby Version 

A secondary version of the software that has been downloaded on 
the node, but which is not currently active. This could be either an 
older software version that remains available as a backup or a newer 
version that has been downloaded but not yet applied. 

Target Version 
The latest software version to be downloaded on the node. If this 
download has been activated, then the Target Version is the same 
as the Running Version. 

Last Requested The last software download action requested on the node. 

NMS State 
The current state of the NMS. This will be idle unless a download is 
in progress, an activation of a new download is pending, or an 
activation is in progress. 

Node State 
The current state of the node. This will be idle unless a download is 
in progress. 

Last Updated 
The date and time when the current software status information was 
last updated from the node. 

Software Activation 
The data at which Netspan first detected that software version was 
running on the node. 

Running Version Checksum 
The data integrity checksum for the software version currently 
running in the node. 

9. Table 24 shows an example of how the software status information would be displayed during 
the process of upgrading from software version 5.6.7.8 to 9.10.11.12. 

Table 24. Example Current Software Status Table during an Upgrade 

Image 
Type 

Running 
Version 

Standby 
Version 

Target 
Version 

Last 
Requested 

NMS 
State 

Node 
State 

Last 
Updated 

Softwar
e 
Activati
on 

Running 
Version 
Checksum 

1. Before the latest software image is downloaded, the node is running software version 5.6.7.8 with version 1.2.3.4 
available as a back-up. 

LTE 5.6.7.8 1.2.3.4  Idle Idle Idle () 

Last 
update 
from 
node to 

Netspan. 

  

2. Software version 9.10.11.12 is chosen with a request of Activate (Download If Needed). The Target Version field 

is updated with the new software version, and the download is currently in progress as reflected by the status of both 
the NMS and the Node. 

LTE 5.6.7.8 1.2.3.4 9.10.11.12 
Activate 
(Download 
If Needed) 

Downl
oad in 
Progr
ess 

Downlo
ading 
(0-99% 
downlo
aded) 

Last 
update 
from 
node to 
Netspan. 

  

3. The software download is complete, so the Node State field returns to Idle and the NMS State moves to Activate 
pending as the software now needs to be activated. The Standby Version field is updated to show the version of the 

newly downloaded software that is waiting to be activated on the node. 
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Image 
Type 

Running 
Version 

Standby 
Version 

Target 
Version 

Last 
Requested 

NMS 
State 

Node 
State 

Last 
Updated 

Softwar
e 
Activati
on 

Running 
Version 
Checksum 

LTE 5.6.7.8 9.10.11.12 9.10.11.12 
Activate 
(Download 
If Needed) 

Activa
te 
pendi
ng 

Idle 
(100% 
downlo
aded) 

Last 
update 
from 
node to 

Netspan. 

  

4. The newly downloaded software is activated, as seen in the NMS State field. 

LTE 5.6.7.8 9.10.11.12 9.10.11.12 
Activate 
(Download 
If Needed) 

Activa
te in 
progre

ss 

Idle 
(100% 
downlo

aded) 

Last 
update 
from 
node to 

Netspan. 

  

5. The software activation is complete, so the Running Version field updates to show the new software version running 
on the node. The Standby Version is now the previous running software version which is still available on the node if 
required, and the NMS State returns to Idle. 

LTE 9.10.11.12 5.6.7.8 9.10.11.12 
Activate 
(Download 
If Needed) 

Idle Idle () 

Last 
update 
from 
node to 
Netspan. 

  

10. Once the upgrade is complete, the Running Version field in the Current Software Status table 
shows the updated software version. 

6.5 How to Upgrade Multiple Nodes per Hardware Type 

Where a network has multiple nodes running on the same hardware type, Netspan provides you with 
the ability to upgrade the software on all of these nodes simultaneously rather than having to upgrade 
them individually as described in How to Upgrade the Software on a Node. 

In full Netspan deployment, it is likely that you would want to install the software on a single node first 
and then roll it out to multiple nodes once performance has been verified. 

To upgrade multiple nodes per hardware type: 

1. Login to Netspan using an account with administrator privileges. 

2. On the main Netspan menu, choose Software Management > Node Software. The Node 
Software screen will be displayed with a list of all nodes currently available in Netspan along 
with their current software status. 

Figure 202: Node Software Screen 
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3. Click on the Filter toggle button, select Image Type from the drop-down list, select LTE from 
the drop-down list, and click Search. The list of nodes is automatically filtered based on your 
selected criteria.  

Figure 203: Filtered Node Software Screen 

 

4. In the resulting filtered list of nodes, select all the nodes that you want to upgrade as a batch 
(up to 1000) by using Shift + click. Click Manage at the bottom of the screen to display the 
details of your selected nodes on the Node Management screen. 

5. Select the Software tab for your chosen nodes. This shows details of the software that is 
currently running on the nodes as well as enabling you to download new software. 

Figure 204: Multiple Node Management Screen 

 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  127 

6. In the Configure Software Download area, click Edit. This will open the Edit Node screen. 

Figure 205: Edit Node Screen 

 

7. You can now specify the new software to install. See Table 25 or a full description of the fields 
that you need to complete. 

Table 25. Configure Software Download Parameters 

Parameter Description 

Request 

Choose your required action from the available list.  

Idle – no activity has been requested. 

Download Only – the software to be activated manually at a later 

date using the Activate option is downloaded to the storage bank. 
Download and activate are kept as separate steps to control when 
service outages occur, as the process of activating a software 
change causes a service outage. Note: this option is not available if 

you are upgrading an iBridge 440 node. 

Activate (Download If Needed) – the software is downloaded to the 

storage bank and is then applied without further user intervention. 
There will be no further warnings before the nodes are updated with 
the new software. This is service affecting. 

Abort – cancels the currently running process. 

Software Image 

A drop-down list of applicable software images currently available in 
Netspan will be populated according to your selection in the 
Software Type field. Choose the one you want to install on the 

nodes. 

Between 

Enables you to define a start time, end time, date, and duration for 
the download. This option is provided for situations where you have 
defined service windows in which you carry out network maintenance 

and upgrades. 

Maintenance Window 

If selected, this option enables you to specify when you would like 
the software download to run and to be activated, by providing 
additional date, time and duration fields; see the description of the 
Run between fields for details. 

When Single is selected, Activation happens immediately after 
software download. When Both is selected, SW Download and 

Activation can be scheduled separately. 

If left clear, the download and/or activation takes place immediately. 

Edit Clicking on this button allows you to edit the node settings. 

 

Note: This information is not available immediately after adding a node (unless that node is 
online). It is populated by the NMS Software Service by polling the node. 
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Table 26. Current Software Status Table Description 

Heading Description 

Node Name of the node. 

Image Type 
The type of the software image currently installed on the node such 
as LTE, AirSynergy, iBridge 440, etc. 

Running Version The current software version running on the node. 

Standby Version 

A secondary version of the software that has been downloaded on 
the node, but which is not currently active. This could be either an 
older software version that remains available as a backup or a newer 
version that has been downloaded but not yet applied. 

Target Version 
The latest software version to be downloaded on the node. If this 
download has been activated, then the Target Version is the same 
as the Running Version. 

Last Requested The last software download action requested on the node. 

NMS State 
The current state of the NMS. This will be idle unless a download is 
in progress, an activation of a new download is pending, or an 
activation is in progress. 

Node State 
The current state of the node. This will be idle unless a download is 
in progress. 

Last Updated 
The date and time when the current software status information was 
last updated from the node. 

Software Activation 
The data at which Netspan first detected that software version was 
running on the node. 

Running Version Checksum 
The data integrity checksum for the software version currently 
running in the node. 

8. Table 27 shows an example of how the software status information would be displayed during 
the process of upgrading from software version 5.6.7.8 to 9.10.11.12.  

Table 27. Example Current Software Status Table During an Upgrade 

Image 
Type 

Running 
Version 

Standby 
Version 

Target 
Version 

Last 
Requested 

NMS 
State 

Node 
State 

Last 
Updated 

Softwar
e 
Activati
on 

Running 
Version 
Checksum 

LTE 
14.14.00
.010 

14.14.00.
9 

 Idle 
Idle 
pending 

Idle () 
2017-04-
13 
15:34:41 

N/A N/A 

LTE 
15.15.10
.171 

15.15.10.
158 

15.15.10.
171 

Activate 
(Download 
if Needed) 

Activate 
failed 

Idle () 
2017-12-
28 
01:24:42 

N/A N/A 

9. Once the upgrade is complete, the Running Version Checksum field in the Current Software 

Status table will show the updated software version. 

6.5.1 How to Perform a Network-Wide Upgrade 

Netspan provides you with the ability to upgrade the software on all of these nodes in your network 
simultaneously, rather than having to upgrade them individually as described in How to Upgrade the 
Software on a Node. 

In full Netspan deployment, it is likely that you would want to install the software on a single node first, 
and then roll it out across all the nodes in your network once performance has been verified. 
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With little input from the operator, this feature will benefit you with the following: 

 All units are upgraded at once 

 Upgrade is automatic 

To perform a network-wide upgrade: 

1. Choose Software Management > Network-Wide Upgrade menu option. 

Figure 206: Network-Wide Upgrade Menu Option 

 

This will open a dashboard containing the hardware types currently available on your network, 
including a graphical representation showing the state of the nodes and the count of the number 
of nodes in each category. 

The grid view is now replaced with a dashboard to enable faster analysis. Viewing these 
representations (for each hardware type) as a dashboard enables you to perform a quick 
analysis and understand what software is running in the network. 

Figure 207: Software Management (Network-Wide Upgrade) Screen 

 

For each hardware category, there is an Edit button, which enables you to start the batch 
software upgrade process. 

Figure 208: Software Management (Network-Wide Upgrade) - Edit Button 

 

2. Click the Edit button applicable to the hardware type whose network-wide software upgrade 
you want to perform. An Edit pop-up window displaying the details listed in Table 28 appears. 
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Figure 209: Network-Wide Upgrade - Edit Window 

 

Table 28. Network-Wide Upgrade - Edit Window Properties 

Property Description 

Version 
Shows the existing software image on the 
selected nodes. 

Count 
Specifies the number of nodes running a specific 
software version. 

Edit 
Select this checkbox if you want to perform a 
network-wide upgrade for that batch of nodes. 

Request 

Make one of the following selections in this field 
to define what action you want to perform: 

Idle – no activity has been requested. 

Download Only– the software to be activated 
manually (at a later date using the Activate 

option) is downloaded to the storage bank 
immediately if the Configure Maintenance 
Windows is set to None. When Single is 
selected, you can schedule SW Download. The 

download and activate actions are kept as 
separate steps to control when service outages 
occur because the process of activating a 
software change might cause a service outage. 
Note: this option is not available if you are 

upgrading an iBridge 440 node. 

Activate (Download If Needed) – the software 

is downloaded to the storage bank and is then 
applied without further user intervention if the 
Configure Maintenance Windows is set to 
None. When Single is selected, Activation 

happens immediately after software download. 
You can schedule the software download. When 
Both is selected, SW Download and Activation 

can be scheduled separately. 

There will be no further warnings before the 
nodes are updated with the new software. This is 
service affecting. 

Abort – cancels the currently running process. 

Software Image 

A drop-down list of applicable software images 
currently available in Netspan will be populated 
according to your selection in the Software Type 

field. Choose the one you want to install on the 

nodes. 

Maintenance Windows 
Appears only when Request is set to Download 
Only or Activate (Download If Needed). 
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If selected, this option enables you to specify 
when you would like the software download to 
run and to be activated, by providing additional 
date, time and duration fields; see the description 
of the Between field for details. 

When Request is set to Download Only:  

 Select Single to schedule the software 

download process. 

 Select None for the download process 

to take place immediately. 

When Request is set to Activate (Download If 
Needed): 

 Select Single to schedule the software 

download process. 

 Select Both to separately schedule the 

software download and activation 
processes. 

 Select None for the software activation 

process to take place immediately. 

Between 

Enables you to define a start time, end time, 
date, and duration for the download. This option 
is provided for situations where you have defined 
service windows in which you carry out network 
maintenance and upgrades. 

OK 
Click this button to progress with the selected 
request. 

Cancel Click this button to cancel the selected request. 

3. To continue with the network-wide upgrade process, in the Edit pop-up window, select the Edit 
checkbox of the software version that you want to upgrade. 

In the given example, the software version 71.13.60.0 is upgraded to 71.6.20.6 with the 

Request set to (Activate Download If Needed). 

Figure 210: Enabling the Edit Checkbox (Example) 
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From the Software Image drop-down list, choose the software image that you want to apply to 
the selected batch of nodes. 

Figure 211: Selecting the Software Image (Example) 

 

You may schedule the activation process if you want it to take place later at a designated time, 
for example, if you want software upgrade to take place during periods of low network use. 

Figure 212: Scheduling Software Upgrade 

 

If the Configure Maintenance Windows is set to None, there will be no further warnings before 
the software upgrade takes place, so it is important that you are aware that your actions here 
will be service affecting 

For more information on other options that you can choose from the Request drop-down list, 
see Table 28. 

4. Click OK to initiate your request. 

5. In the Result pop-up window, click OK. 
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Figure 213: Result Window (Example) 

 

Once the upgrade has been initiated, the dashboard shows the progress by changing the State 
of the nodes that were selected for upgrade from Idle to Activate in progress. The green 
segment of the graphical representation indicates the upgrade progress. The faded grey 
segment represents the nodes that were not selected for the batch upgrade. 

Figure 214: State - Activate in Progress (Example) 

 

During the upgrade process, the dashboard displays status information on your software 
upgrade request, detailing how many nodes of your selected population are pending, in 
progress, have completed, or failed the download and/or activation process. 

After completing the software upgrade process, the State changes back to Idle to denote that 
there are no pending requests. 

Figure 215: Upgrade Complete (Example) 

 

You also have the option to use the Node Search feature to filter a list of nodes which are 
running a specific software, and then perform a network-wide software upgrade. For more 
information on how to perform this search, see Node Search.  
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7 Alarm Management 

On the Active and Historical Alarms screens of the Netspan UI, you will be able to view details of the 
network and the equipment alarms that are both currently active and that have been either cleared or 
in existence for long enough to now be granted historical status. 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

An alarm in Netspan indicates the presence of a fault condition on either the Netspan server or any 
piece of node equipment. The raising and clearing of alarms is triggered by an associated Netspan 
event, where an event is a notification indicating the occurrence of a condition on the Netspan server 
or on the node equipment. 

Not all events raise alarms, but only those that notify of fault conditions. Depending on the severity of 
the event, Netspan raises an alarm until the underlying condition is cleared. Resolving a fault in the 
network clears the associated alarm, but an event remains until it is cleared from the Netspan event 
buffer. 

Occurrences of alarms are written to the Netspan database and their details are displayed in the UI. 
This section explains how you can view and manage alarms using the Netspan’s UI, covering: 

 How to View Active Alarms 

 How to View Historical Alarms 

 How to Acknowledge Alarms 

 How to Delete Alarms 

 How to Edit Alarms 

 How to Export Alarms View into an Excel File 

 How to Understand Alarm Details 

 How to View and Edit Alarm Types 

 How to View Alarm Timeline Graph 

 

Note: In addition to the alarm management functionality described in this section, Netspan also 
provides you with the ability to view a geographical map of the nodes that have reported alarm 
conditions and a colour-coded timeline of the alarms that have been raised on the node population 
over an adjustable time period. These two features are not included here, but are explained in detail 
in ARD-D01018 Netspan Administration Guide. 
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7.1 How to View Active Alarms 

When an alarm is triggered on a node, the details of that alarm are logged and displayed in the Netspan 
UI. You can view active and How to View Historical Alarms in the UI to see full details of problems that 
have occurred so that you can take appropriate action if it is required. 

Active alarms include all the alarms that are currently in your network, reported to Netspan, and are 
stored in the database. 

To view an active alarm: 

1. Choose Fault Management > Active Alarms menu option. This will open a List screen, 
containing the alarms currently active on your network’s nodes. 

Figure 216: Active Alarms List Screen 

 

2. It is possible that there could be hundreds of alarms live in your system, so Netspan provides 
you with a Filter field which enables you to reduce the list of alarms to just those you are 
interested in. The available filters are: 

Table 29. Active Alarm Search Filters 

Filter Description 

Severity Displays the alarms that match your specified severity level. 

Cleared 
Displays the time (YYYY-MM-DD HH:MM:SS) when the alarm was 
cancelled. 

Alarm ID Displays the alarm that matches the alarm ID of a specific alarm. 

Alarm Type Displays the alarms that match your specified alarm type. 

Alarm Type ID Displays the alarms that match your specified alarm type. 

Category Displays the alarms that match your specified category. 

Source Type Displays the alarms that match your specified source type. 

Source Name 
Displays the alarms that math your specified source name (node 
name) and condition. 

Unique ID 
Displays the alarms that match your specified Unique ID of the 
alarm. 

Alarm Info Displays the alarms that match the specified alarm info. 

Ack Displays the alarms that match the condition. 
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Filter Description 

User 
Displays the user that matches the condition. If the alarm is not ack 
or cancelled the user is blank.  

Last Acknowledged 
Displays the last acknowledged alarms matching the date and time 
and condition. 

Alarm Count 
Displays the alarms that are received with same alarm ID and 
matching the condition. 

First Raised 
Displays the alarms that match the first date and time on which the 
alarm was raised and a condition. 

Last Raise Event 
Displays the alarms that match the last date and time the alarm was 
raised and a condition. 

Last Cleared Displays the last time the alarm was cleared.  

MAC Address Displays the MAC address of the source node. 

Last Changed 
Displays the Last Changed Alarms based on a specific Date 
Search. 

3. Netspan also enables you to search for specific keywords or phrases in the list of active alarms. 
To enable this functionality, click the Filter toggle button, select the filter type from the drop-
down option, select an appropriate option from the adjacent drop-down option, and click on 
Search. 

4. Once you have filtered the list of alarms, double click the one you want to investigate in detail. 
The Alarm Details screen will be displayed, providing you with extensive information on the 
nature of the alarm, including the node on which the alarm was raised, the unique alarm ID, its 
severity level, when it was raised, and so on. 

Figure 217: Active Alarm Details Screen 
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Note: For an explanation of what may have caused a particular type of alarm and the 
recommended actions to clear it, see ARD-D00742 Netspan Alarms and Events Reference 
Guide. 

Table 30 lists details of all the fields displayed on the Alarm Details screen. 

Table 30. Alarm Properties and Descriptions 

Property Description 

Alarm Type Specifies the type of the alarm. 

Source Name 
Specifies the name of the managed element on which the alarm is 
raised. 

Source ID Specifies the ID of the managed element on which the alarm is raised. 

Alarm ID 
Specifies the ID of the selected alarm. 

Note: Netspan generates a unique alarm ID for every new alarm. 

Alarm Properties 

Alarm Info Provides information on the selected alarm. 

Severity Specifies the current severity level of the alarm. 

Acknowledged If selected, it indicates that a specific user is investigating that alarm. 

User Name 
Specifies the name of the user who acknowledged the alarm (if the 
alarm is acknowledged). 

First Raised Specifies the date and time on which the alarm was first raised. 

Last Raised Specifies the date and time on which the alarm was last raised. 

Alarm Count 
Specifies the number of times the alarm changed from cleared to 
raised state. 

Raise Events Specifies the number of events raised for the selected alarm. 

Comments 
Shows any user-defined comments related to the instance of the 
alarm. 

Alarm Type Properties 

ITU Event Type Specifies the ITU event type of the alarm. 

Probable Cause Lists the possible causes that triggered the alarm. 

Description Provides a description of the alarm. 

User Description Displays any descriptions that users have added to the alarm. 

Alarm History  

Lists the history of the alarm status changes. 

5. Click Save to close the Alarm Details screen and return to the Active Alarms List screen. 

7.2 How to View Historical Alarms 

When an alarm is triggered on a node, the details of that alarm are logged and displayed in the Netspan 
UI. After a configurable period of time, most alarm types will be cleared automatically which moves 
them from the status of ‘active’ to ‘historical’. You can view How to View Active Alarms and historic 
alarms in the UI to see full details of problems that have occurred so that you can take appropriate 
action if required. 
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To view an historical alarm: 

1. Choose Fault Management > Historical Alarms menu option. This will open a List screen 
containing the historical alarms which were previously active on your system. 

Figure 218: Historical Alarms List Screen 

 

2. It is possible that there could be hundreds or even thousands of historical alarms in your system, 
so Netspan provides you with a Filter field which enables you to reduce the list of alarms to 
just those you are interested in. The available filters are: 

Table 31. Historical Alarm Search Filters 

Filter Description 

Severity Displays the alarms that match your specified severity level. 

Alarm ID Displays the Alarm that matches the Alarm ID of a specific alarm. 

Alarm Type Displays the alarms that match your specified alarm type. 

Alarm Type ID Displays the alarms that match your specified alarm type. 

Category Displays the alarms that match your specified category. 

Source Type Displays the alarms that match your specified source type. 

Source Name 
Displays the alarms that match your specified source name (node 
name) and condition. 

MAC Address Displays the MAC address of the source node. 

Last Changed Displays the Last Changed Alarms based on a specific Date Search. 

3. Netspan also enables you to search for specific keywords or phrases in the list of historical 
alarms. To enable this functionality, click the Filter toggle button, select the filter type from the 
drop-down option, select an appropriate option from the adjacent drop-down option, and click 
on Search. 

4. Once you have filtered the list of alarms, double click the one you want to investigate in more 
detail. The Alarm Details screen will be shown which provides you with extensive information 
on the nature of the alarm, including the node on which the alarm was raised, the unique alarm 
ID, its severity level, when it was raised, and so on. 
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Figure 219: Alarm Details Screen 

 

Note: For an explanation of what may have caused a particular type of alarm and the 
recommended actions to clear it, see ARD-D00742 Netspan Alarms and Events Reference 
Guide. 

Table 32 lists the details of all the fields that you can find on the Edit Alarm page. 

Table 32. Alarm Properties and Descriptions 

Property Description 

Alarm Type Specifies the type of the alarm. 

Source Name 
Specifies the name of the managed element on which the alarm is 
raised. 

Source ID Specifies the ID of the managed element on which the alarm is raised. 

Alarm ID 
Specifies the ID of the selected alarm. 

Note: Netspan generates a unique alarm ID for every new alarm. 

Alarm Properties 

Alarm Info Provides information on the selected alarm. 
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Property Description 

Severity Specifies the current severity level of the alarm. 

Acknowledged If selected, it indicates that a specific user is investigating that alarm. 

User Name 
Specifies the name of the user who acknowledged the alarm (if the alarm 
is acknowledged). 

First Raised Specifies the date and time on which the alarm was first raised. 

Last Raised Specifies the date and time on which the alarm was last raised. 

Alarm Count 
Specifies the number of times the alarm changed from cleared to raised 
state. 

Raise Events Specifies the number of events raised for the selected alarm. 

Comments Shows any user-defined comments related to the instance of the alarm. 

Alarm Type Properties 

ITU Event Type Specifies the ITU event type of the alarm. 

Probable Cause Lists the possible causes that triggered the alarm. 

Description Provides a description of the alarm. 

User Description Displays any descriptions that users have added to the alarm. 

Alarm History  

Lists the history of the alarm status changes. 

5. Click Save to close the Alarm Details screen and return to the Historical Alarms List screen. 

7.3 How to Acknowledge Alarms 

An acknowledged alarm indicates that a specific user is investigating that alarm. Any user can 
acknowledge an alarm. 

To acknowledge an alarm: 

1. Choose Fault Management > Active Alarms menu option. This will open a List screen 
containing the alarms currently active on your network’s nodes. 

Figure 220: Active Alarms List Screen 
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2. Select the alarm that you want to acknowledge. The Acknowledge button will be enabled at 
the bottom of the screen when you select an alarm. 

Note: You can acknowledge multiple alarms simultaneously by using Ctrl + click to select 
multiple alarms or Shift + click to select an array. 

3. Click the Acknowledge button. The checkbox in the Ack column for your alarm will be selected, 
indicating that the alarm has been acknowledged. 

An unacknowledged alarm indicates that the user who initially acknowledged the alarm is no longer 
investigating that alarm. Alarms can only be unacknowledged by an administrator or by the user who 
acknowledged the alarm. 

To unacknowledge an alarm: 

1. Choose Fault Management > Active Alarms menu option. This will open a List screen 
containing the alarms currently active on your network’s nodes. 

Figure 221: Active Alarms List Screen 

 

2. Select the alarm that you want to unacknowledge. Alarms that are currently acknowledged are 
identified by having the checkboxes in the Ack column selected. The Unacknowledge button 
will be enabled at the bottom of the screen when you select an alarm. 

Note: You can unacknowledge multiple alarms simultaneously by using Ctrl + click to 
select multiple alarms or Shift + click to select an array. 

3. Click the Unacknowledge button. The checkbox in the Ack column for your alarm is now 
cleared, indicating that the alarm is no longer acknowledged. 

7.4 How to Delete Alarms 

You can delete alarms through the Netspan UI so that they no longer appear in the list of active alarms. 
You might want to do this if, for example, you would rather remove alarms that are generated as part 
of the normal operation of nodes in your network so that it will be easier to see the alarms being raised 
by genuine problems or fault conditions. 

Note: Airspan recommends that you do not delete an active alarm without identifying the root cause 
and resolving the fault. Otherwise, the alarm might recur. 
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To delete an active alarm: 

1. Choose Fault Management > Active Alarms menu option. This will open a List screen 
containing the alarms currently active on your network’s nodes. 

Figure 222: Active Alarms List Screen 

 

2. Select the alarm that you want to delete. The Delete button will be enabled at the bottom of the 
screen when you select an alarm. 

Note: You can delete multiple alarms simultaneously by using Ctrl + click to select multiple 
alarms or Shift + click to select an array. 

3. Click the Delete button. Your selected alarms will be removed from the active alarms list. 

4. To view deleted alarms, go to the Historical Alarms page. This lists all historic alarms, both 
deleted and active. For further instructions, see How to View Historical Alarms. 

7.5 How to Edit Alarms 

When you are working with alarms, you have the option of editing the alarm’s details to leave your own 
comments on the particular instance of an alarm. You can add comments to either active or historical 
alarms. 

To edit the details of an alarm:  

1. Choose Fault Management > Active Alarms menu option. This will open a List screen 
containing the alarms currently active on your network’s nodes. 

Figure 223: Active Alarms List Screen 
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2. Filter the alarms list if required using the Filter field as described in How to View Active Alarms 
and select the alarm for which you want to add comments.  

3. Either click the Edit button or double click the selected alarm to open the Alarm Details screen. 
One of the panels displayed on this screen has the title Alarm Properties. 

Figure 224: Alarm Properties Panel 

 

4. While most of the fields are read only as the information is pre-populated, click in the 
Comments text field and enter specific comments you have for this instance of the alarm.  

5. Click Save. Your edits will be saved and you will be returned to the Active Alarms List screen.  

Note: To add a comment to an historical alarm, the process is exactly the same, but choose 
Fault Management > Historical Alarms menu option in step 1. 

7.6 How to Export Alarms View into an Excel File 

When you are working with alarms in Netspan, you have the option of either viewing various alarm 
details in the Netspan UI or you can export them as an Excel file to your machine so that you can 
examine, sort, and interrogate them as you please. This applies to both active and historical alarms. 

To export the alarms view into an Excel file: 

1. Choose Fault Management > Active Alarms menu option. This will open a List screen 
containing the alarms currently active on your network’s nodes. 

Figure 225: Active Alarms List Screen 

 

2. Click Export to export the alarms held in Netspan’s database. Your browser will show a 
message asking whether you want to open or save Export.csv, the Excel file generated by 
Netspan for export. Click Open or Save as appropriate. 

Figure 226: Export Excel File Message 
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3. If you choose Open, your machine will launch Excel and will display the exported file of alarm 
details.  

Figure 227: Excel File View 

 

4. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 228: Export Confirmation Message 

 

From here, you can Open the exported file, Open folder which will display a Browse dialog 
open at the exported file’s location, or View downloads which will open the View Downloads 
dialog in which you can open the exported file or go to its downloaded location.  

Note: To export alarms view for historical alarms, the process is exactly the same, but 
choose Fault Management > Historical Alarms menu option in step 1. 

7.7 How to Understand Alarm Details 

When you open the alarms list screen, either for active or historical alarms, the Netspan UI will display 
range of details about the alarms in tabular format. The information shown in this table is described in 
Table 33. 

Table 33. Alarm List Screen Information 

Filter Description 

Severity Displays the alarms that match your specified severity level. 

Cleared 
Displays the time (YYYY-MM-DD HH:MM:SS) when the alarm was 
cancelled. 

Alarm ID Displays the alarm that matches the alarm ID of a specific alarm. 

Alarm Type Displays the alarms that match your specified alarm type. 

Alarm Type ID Displays the alarms that match your specified alarm type. 
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Filter Description 

Category Displays the alarms that match your specified category. 

Source Type Displays the alarms that match your specified source type. 

Source Name 
Displays the alarms that math your specified source name (node name) and 
condition. 

Unique ID Displays the alarms that match your specified Unique ID of the alarm. 

Alarm Info Displays the alarms that match the specified alarm info. 

Ack Displays the alarms that match the condition. 

User 
Displays the user that matches the condition. If the alarm is not ack or 
cancelled the user is blank.  

Last Acknowledged 
Displays the last acknowledged alarms matching the date and time and 
condition. 

Alarm Count 
Displays the alarms that are received with same alarm ID and matching the 
condition. 

First Raised 
Displays the alarms that match the first date and time on which the alarm 
was raised and a condition. 

Last Raise Event 
Displays the alarms that match the last date and time the alarm was raised 
and a condition. 

Last Cleared Displays the last time the alarm was cleared.  

MAC Address Displays the MAC address of the source node. 

Last Changed Displays the Last Changed Alarms based on a specific Date Search. 

As explained in Table 33, included on the alarm list screen is a colour-coded icon indicating the severity 
of each alarm. Table 34 explains the severity levels and associated icon colours of the alarms in 
Netspan. 

Table 34. Alarm Severity Levels 

Severity Color Icon Description 

Critical Red  Indicates a critical condition. 

Major Orange  
Indicates that there is a high risk of loss of 
service.  

Minor Yellow  

Indicates that there is a partial risk of loss of 
service. 

Note: Perform corrective actions to avoid a more 

severe service-affecting fault. 

Warning Cyan  

Signifies the presence of a warning condition.  

Note: Perform corrective actions to avoid a more 

severe service-affecting fault. 

Normal Green  Indicates that the alarm is cleared. 

Indeterminate Magenta  

Indicates that the cause of the Alarm cannot be 
determined at this time (or the node is in 
maintenance mode). 

From the alarm list screen, double click on any individual alarm to see further information relating to 
that particular alarm. This will open the Alarm Details screen. 



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  146 

The information shown on the Alarm Details screen for any individual alarm is described in detail in How 
to View Active Alarms.  

7.8 How to View and Edit Alarm Types 

When you are working with alarms, Netspan enables you to view and, to an extent, edit the alarm types 
present in the system. You cannot add or remove alarm types, but you can see the details of each and 
change some of the parameters if required.  

Note: For a full list of the alarm types configured in a particular software release of Netspan, see 
ARD-D00742 Netspan Alarms and Events Reference Guide. 

To view and edit alarm types: 

1. Choose Fault Management > Alarm Types menu option. This will open a List screen 
containing all alarm types currently configured in Netspan. 

Figure 229: Alarm Types List Screen 

 

2. While the list screen will be read only for you to see the details of the currently configured alarm 
types, you can drill down into individual alarm type details. Either double click an alarm type in 
the list or select it and click Edit to open the Edit Alarm Type screen for your selected type. 

Figure 230. Edit Alarm Type Screen 
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3. Table 35 explains the fields present on this screen which are read only and which you can edit. 

Table 35. Fields on the Edit Alarm Type Screen 

Field Description 

Properties 

Name Provides the name of the alarm type (read only). 

Category Specifies the category of the alarm type (read only). 

ITU Event Type Specifies the ITU event type of the alarm type (read only). 

Severity 
Specifies the default severity level of the alarm type. Can be changed 
by making a selection from the drop-down list if required. 

Raise 
Specifies whether the alarm type can be raised in your Netspan 
instance or not. Select the checkbox for the alarm type to be raised, 

clear it to disable the alarm so this type cannot be raised in your system. 

Forward 
Specifies whether this alarm type is forwarded by NBIF (if the NBIF 
alarm forwarding is configured). Select the checkbox for the alarm type 
to be forwarded, clear it to disable forwarding. 

Alarm Sync Enabled 
Specifies whether alarm synchronization is enabled for the alarm type 
(read only). 

Auto Delete Cleared Time 
(hours) 

Specifies the number of hours after which a cleared alarm of this type 
will be deleted automatically. Can be changed if required. 

Descriptions 

Probable Cause 
Lists the possible causes that could trigger an instance of this alarm 
type (read only). 

Description Provides the description of the alarm type (read only). 

User Description Use this field to add your own description of the alarm type. 

Related Event Types 

Lists the event types linked to the selected alarm type. 

4. Once you have completed your edits, click OK to close the screen and return to the list of Alarm 
Types. 
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7.9 How to View Alarm Timeline Graph 
Netspan provides a timeline view of the alarms in a graphical format to assist the overall management 
of the network. 

Note: To enable this feature, you need a suitable Netspan license - Graphical Performance 
Management Licence. 

To view the Alarm Timeline graph, on the Netspan main menu, select Configuration Management > 
Node > Node. Select the node for which you want to view the timeline and click on Manage. Go to the 
Alarms/Events tab and select Display Type as Alarm Timeline from the drop-down option available 
to view Node Alarm Timeline. 

Figure 231: Alarm Timeline Graph 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  149 

7.9.1 Selecting Alarm Period 

You can set the alarm period to one of the following: 

 Last Hour 

 Last Day 

 Last Week 

 Last Month 

 All 

 Date Range 

Figure 232: Selecting Period 
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8 Performance Management 

Performance management is a Netspan function that collects performance data that can be used to 
analyse and optimise a given configuration of the network. This functionality identifies potential issues 
and thereby reduces call drops, improves the QoS, enhances user experience, and allows optimum 
network usage. 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

The performance data that is collected from the network elements (nodes) includes counters, KPIs, and 
statistics. Using the Netspan UI, you can view this data in either tabular format so that you can see 
individual values and readings or you can opt to see it rendered in graphical format as charts. In either 
case, you have the option of viewing different groups of statistics at different measurement intervals 
and can choose to manually update the data by getting the latest real-time information from the node.  

This section explains how to: 

 How to View Performance Statistics in Table Format 

 How to View Performance Statistics in Chart Format 

 How to Work with Performance Charts 

 How to Export Performance Statistics into an Excel File 

 KPI Search 

8.1 How to View Performance Statistics in Table Format 

For each of the nodes operating on your network, Netspan provides you with the ability to view the 
statistical performance of the node displayed in either table or chart format.  This section describes how 
to view the performance statistics in table format. See How to View Performance Statistics in Chart 
Format for details on how to view the information in graphical format. 

To view a node’s performance statistics in table format: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 233: Node List Screen 
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2. Find the node in the list for which you want to view the performance statistics and either double 
click on it or select it and click Manage. Either operation opens the Node Management screen 
for your selected node. Click the Statistics tab and choose one of the Data Grid options in the 
Display field. Statistics for your selected node will be shown in a tabular display. 

Figure 234: Node Management Statistics Tab - Table Display 

 

3. The Display field gives you the option of viewing statistics gathered hourly, daily, or in raw 
format, which means that statistical data is taken and given a specific time/date stamp, rather 
than averaged over an hour or over a day. 

4. Depending on the node type you are viewing the data, the statistics are collected into different 
groups. You can choose to view a particular group of statistics using the drop-down list in the 
Statistics Type field. The contents of this list will vary depending on the node type you are 
viewing. Table 36 lists the statistics type entries per node type. 

Table 36. Statistics Type Groups per Node Type  

Node Type Statistics Type Groups 

eNodeB 

 ANR 

 Backhaul QoS 

 Carrier Aggregation 

 Cell Level Radio Bearer 
QoS 

 Cell Level Radio Bearer 
QoS per QCI 

 CMAS 

 CSFB 

 CSFB per PLMN 

 Dynamic ACB 

 eMBMS 

 Enb Positioning 
Measurements 

 Equipment Measurements 

 E-RAB 

 MME Overload 

 Neighbour Management  

 Paging 

 Per PLMN 

 Per PLMN Per QCI 

 Positioning Measurements 

 RACH Access Delay 

 RACH Preambles Sent 

 Radio Resource Utilization 

 Radio Resource Utilization for 
VoLTE per MCS 

 Radio Resource Utilization per 
ITBS 

 Radio Resource Utilization per 
MCS 

 Radio Resource Utilization per 
QCI 
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Node Type Statistics Type Groups 

 E-RAB per QCI 

 Ethernet Counter Per Port 

 ETWS 

 Events 

 GTP 

 Handover 

 Handover Per QCI 

 Handover Per Target Cell 

 HARQ 

 Incoming Handover 

 Intra eNB Load Balancing 

 Link Adaptation 

 Lite CoMP 

 RF Measurements 

 RRC Connection 

 RRC Connection Per EARFCN 

 RSRP Measurement 

 RSRQ Measurement 

 SON 

 SON Per MCS 

 Sub-band CQI 

 Timing Advance 

 UE-Associated Logical S1-
Connection 

 VoLTE Quality 

 VoLTE WB CQI 

iBridge 440 
 IP Stats 

 QoS Stats 
 RF Stats 

iBridge 460 Base/Term 

 iBridge Base Air Interface 
Stats 

 iBridge Base Term RF 
Stats 

 iBridge Base Air Interface Usage 
Stats 

 iBridge Base Term Data Stats 

Relay 
 Interface Stats 

 Neighbour Interface Stats 

 Radio Stats 

 PDN Availability Per APN Stats 

Relay eNodeB 

 LTE ANR 

 LTE Backhaul QoS 

 LTE Carrier Aggregation 

 LTE Cell Level Radio 
Bearer QoS 

 LTE Cell Level Radio 
Bearer QoS per QCI 

 LTE CMAS 

 LTE CSFB 

 LTE CSFB per PLMN 

 LTE Dynamic ACB 

 LTE eMBMS 

 LTE Enb Positioning 
Measurements 

 LTE Equipment 
Measurements 

 LTE E-RAB 

 LTE E-RAB per QCI 

 LTE Paging 

 LTE Per PLMN 

 LTE Per PLMN Per QCI 

 LTE Positioning Measurements 

 LTE RACH Access Delay 

 LTE RACH Preambles Sent 

 LTE Radio Resource Utilization 

 LTE Radio Resource Utilization 
for VoLTE per MCS 

 LTE Radio Resource Utilization 
per ITBS 

 LTE Radio Resource Utilization 
per MCS 

 LTE Radio Resource Utilization 
per QCI 

 LTE RF Measurements 

 LTE RRC Connection 

 LTE RRC Connection per Earfcn 

 LTE RSRP Measurement 
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Node Type Statistics Type Groups 

 LTE Ethernet Counter Per 
Port 

 LTE ETWS 

 LTE Events 

 LTE GTP 

 LTE Handover 

 LTE Handover Per QCI 

 LTE Handover Per Target 
Cell 

 LTE HARQ 

 LTE Incoming Handover 

 LTE Intra eNB Load 
Balancing 

 LTE Link Adaptation 

 LTE Lite CoMP 

 LTE MME Overload 

 LTE Neighbour 
Management 

 LTE RSRQ Measurement 

 LTE SON 

 LTE SON per MCS 

 LTE Sub-band CQI 

 LTE Timing Advance 

 LTE UE PRACH Initial Timing 
Advance 

 LTE UE- Associated Logical S1- 
Connection 

 LTE VoLTE Quality 

 LTE VoLTE WB CQI 

 Relay Neighbour Interference 
Stats 

 Relay PDN Availability Per APN 
Stats 

 Relay Per MCS Stats 

 Relay Per QCI Stats 

 Relay Radio Stats 

iBridge2 Base/Term 

 iBridge2 Device Stats 

 iBridge2 RF Stats 

 iBridge2 Throughput Stats 

 iBridge2 Ethernet Stats 

 iBridge2 QoS Stats 

A description of the individual counters and KPIs that are found within these groups is provided 
in ARD-D00740 Netspan Counters and KPIs Reference Guide. 

5. When you have finished reviewing the performance statistics for the selected node, click Close 
to return to the node list screen. 

8.2 How to View Performance Statistics in Chart Format 

For each node operating on your network, Netspan provides you with the ability to view the statistical 
performance of the node displayed in either table or chart format. 

This section describes how to view the performance statistics in chart format. See How to View 
Performance Statistics in Table Format for details on how to view the information in tabular format. 
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To view a node’s performance statistics in chart format: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 235: Node List Screen 

 

2. Find the node in the list for which you want to view the performance statistics and either double 

click on it or select it and click Manage. Either operation opens the Node Management screen 

for your selected node. Click the Statistics tab and choose the Chart option in the Display 

field. Statistics for your selected node are displayed as a chart. 

Figure 236: Node Management Statistics Tab - Chart Display 
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3. The statistics chart uses interactive illustrations to summarise and display statistics of various 
counters and KPIs in an easily understandable format. The chart presents information related 
to different statistics types. For each statistics type, you can specify a date range and compare 
values across specified dates. For further details of how to change the display of the chart and 
how to alter the data shown, see How to Work with Performance Charts. 

4. When you have finished analyzing the charts, click Close to return to the node list screen. 

8.3 How to Work with Performance Charts 

As described in How to View Performance Statistics in Chart Format, you can view the performance 
statistics of a given node in the Netspan UI in a graphical format. The chart display includes the following 
features: 

 Provides multiple filter options based on the statistics type, date range, date type (raw, hourly, 
daily), and associated statistics features. 

 Displays counters in chart format from the nodes in real time using the Reload button which 

proves useful in troubleshooting situations. 

 Enables you to resize the graphs and customize the display interval. 

8.3.1 Common Controls 

Regardless of the node type you are examining statistics, certain controls on the chart display are 
common across all statistics type displays. 

Table 37. Common Chart Controls 

Control Description 

Date Range 
A drop-down list containing the entries Last Hour, Last Day, All, and Custom. 
This enables you to change the date range of the chart to focus on a 
particular time frame or to view trends over time. 

Data Type 
A drop-down list containing the entries Raw, Hourly, and Daily. Enables you 

to view statistics at different levels of granularity. 

Reload A button that pulls real time data from the node to update the chart. 

All other options are specific to the type of node you are examining the statistics for and the statistics 
type you have selected to display. 

8.3.2 Process 

Regardless of the type of the node you are viewing or the statistics group you have selected, the process 
and principles for using the chart display remain consistent. 

1. Select a set of statistics to display from the Statistics Type drop-down list. The content of this 
list varies according to the type of the node you are examining. 

2. Select an appropriate option from the Display drop-down list to view the data is chart or grid 
format. 

3. Make a selection in the Data Type field to determine the granularity of the data to be displayed. 

4. Change the Date Range to focus on a particular time frame or to view trends over time. 

5. Select the checkboxes/radio buttons of each statistic you want to display on the chart. Each 
time you select or clear a checkbox, the chart will be dynamically redrawn. 

6. Click Reload to pull real time data from the node and have it added to the chart. 
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Depending on the nature of the statistics you are viewing, Netspan renders the chart type most 
appropriate for that data. 

Figure 237: Chart 

 

Note: The formula used by Netspan to calculate the values displayed in the charts are detailed in 
ARD-D00740 Netspan Counters and KPIs Reference Guide.  

8.4 How to Export Performance Statistics into an Excel 
File 

When you are working with a node’s performance statistics in Netspan, you have the option of either 
viewing the performance statistics in the Netspan UI or you can export them as an Excel file on your 
machine so that you can examine, sort, and interrogate them as you please.  

To export a node’s performance statistics into an Excel file: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 238: Node List Screen 
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2. Find the node in the list for which you want to view the performance statistics and either double 
click on it or select it and click Manage. Either operation opens the Node Management screen 
for your selected node. Click the Statistics tab and choose one of the Data Grid options in the 
Display field. Statistics for your selected node will be shown in a tabular display. 

Note: In order to export performance data into an Excel file, you have to view the statistics 

in tabular format. You cannot export the graphical chart view into Excel. 

Figure 239: Node Management Statistics Tab - Table Display 

 

3. Make selections in the Statistics Type drop-down list and Display drop-down list as required 
so that you can view the required groups of statistics at the desired sampling time intervals.  

4. Click Export depending on whether you want to export the statistics for your selected node 
currently held in Netspan’s database. Your browser shows a message asking if you want to 
open or save Export.CSV, the Excel file generated by Netspan for export. Click Open or Save 
as appropriate. 

Figure 240: Export Excel File Message 

 

5. If you choose Open, your machine will launch Excel and will display the exported file of 
performance statistics. 

Figure 241: Excel File View 
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6. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 242: Export Confirmation Message 

 

From here, you have the option to Open the exported file, Open folder which will display a 
browse dialog open at the exported file’s location, or View downloads which will open the View 
Downloads dialog in which you can open the exported file or go to its downloaded location. 

8.5 KPI Search 

The users can quickly find a specific KPI and navigate to the KPI collection that is grouped under the 
statistics type of the counter that you searched for by using the search KPI textbox on the Statistics 
tab of the Node Management page. 

Based on the search string that you enter in the search KPI box, Netspan returns a list of KPIs that 
contain the specified string in their name. From the list, you can select the KPI that you want to 
investigate. Clicking the desired KPI will redirect you to the Netspan screen, displaying the specific 
statistic type (chart or data grid ─ depending on the Display settings). 

To search a KPI: 

1. On the Netspan main menu, select Configuration Management > Node > Node. This will 
open the Node List screen containing the nodes currently visible on your network. 

Figure 243: Node List Screen 

 

2. From the node list, click the node that you want to examine and click Manage. This opens the 
Node Management screen for your selected node. Then, click the Statistics tab. 

Figure 244: KPI Search 

 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  159 

3. Enter the KPI name or part of the KPI name in the search textbox. A drop-down list will be 
displayed for your search.  

Note: The KPI you are searching should have the same node type. Example, if the selected 
node is eNodeB, then the KPI that you are looking for should be of LTE only. If the selected 
node is iBridge LOS, then the KPI that you are looking for should be of iBridge LOS as well, 
else Netspan will not return any result for your search. 

Figure 245: KPI Search 

 

4. Select the desired KPI and the result will be displayed on the Node Management (Statistics 
tab) page. 

Figure 246: Node Management 
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9 Node Management 

The Netspan UI provides you with the ability to view the status of each node in your network so that 
you can review the current configuration, operation, and performance. This functionality includes being 
able to see real-time data from the nodes, but Netspan’s node management capabilities also enable 
you to control the configuration of the nodes remotely, implement a reboot, or even delete a node from 
your network entirely. 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge 

 iRelay 

 Relay eNodeB 

This section explains how to: 

 How to View Node List 

 How to Examine Node Status 

 How to Reboot a Node 

 How to Change Service Status of a Node 

 How to Reprovision a Node 

 How to Receive Updates from a Node 

 How to Edit a Node 

 Multi Edit Nodes 

 Multi Manage Nodes 

 How to Delete a Node 

 How to Obtain Node/Network Inventory 

 How to Set Trap Destinations  
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9.1 How to View Node List 
Netspan’s node management functionality includes the ability to view a list of all nodes present in your 
system. This is the quickest and the easiest way to get a high-level view of nodes in your network before 
having the option of exploring the details of individual nodes in more depth using the processes 
described in the rest of the node management sub-sections in this document. 

To view the node list: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 247: Node List Screen 

 

2. In addition, you have the option to filter the list by node type or by a variety of other criteria 
depending on what you are examining the node list for. The Node Type drop-down field is 
available at the top of the screen and contains a list of different node types present in your 
network. It also has the All Nodes option, which displays all the nodes. Select the node type 
you want, for example: iBridge Term, and the list will be dynamically updated.  

Figure 248: Node Type Selection 

 

3. Moreover, the Node Type filter field provided at the top of the List panel offers various options 
in the drop-down list to filter the nodes displayed according to a number of the parameter 
headings shown on the screen. You can filter the node list by: 

o Managed 

o Not Managed 

o Managed and Online 

o Managed and Not Online 

o PnP Complete 

When you choose one of these options, a further drop-down list will be displayed, which will be 
populated depending on the selection you made in the Filter field. This field operates in 



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  162 

association with your filter choice to refine your filter. For example, if you choose a filter of 
Managed, the options in the for list are True or False, so your list of nodes will be filtered to 
show only managed or unmanaged nodes, depending on your selection. 

Figure 249: Filter Field Selection 

 

4. To supplement the two filter fields, select the filter type from the Node Type drop-down option, 
select an appropriate option from drop-down list, and then click the Edit checkbox. This will 
enable an additional filter option. Select appropriate option from the drop-down lists. 

Figure 250: Filter Option 

 

5. Once you have filtered your node list to find the node you want to view, you can examine the 
node’s status and perform a number of operations on that node. These options are described 
in the other sub-sections of Node Management. 

9.2 How to Examine Node Status 
For each of the nodes operating on your network, Netspan provides you with the ability to examine the 
current status of the node across multiple operational categories so that you can review the node’s 
current configuration, operation, and performance.  

To examine a node’s status: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 251: Node List Screen 
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2. Find the node you want to examine in the list and either double click on it or select it and click 
Manage. Either operation opens the Node Management screen for your selected node. Click 
the Status tab. 

Figure 252: Node Management Status Tab 

 

3. Use the Status Type drop-down list to determine the type of information to be displayed. The 
contents of this list will vary depending on the type of the node you are examining. Table 38 
shows which options are applicable to each node type, covering eNodeB, iBridge 440, iBridge 
460 Base/Term, and iRelay nodes. 

Table 38. Status Type Drop-Down List Content by Node Type 

Status Type 

Node Type 

eNodeB iB440 
iB460 

Base/Term 
Relay 

Relay 
eNodeB 

iBridge2 

Discovered 
Properties      
Commissioned 
Properties      
UE Status and IP 
Throughput      

RF Status      

Sensor Status      
Service Flow 
Status      

SON Status      
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Status Type 

Node Type 

eNodeB iB440 
iB460 

Base/Term 
Relay 

Relay 
eNodeB 

iBridge2 

Licence Status      
Node 
Configuration Log      

eMBMS Status      
Logical IP 
Interface Status      

Network Element 
Status      

CBRS Status      

Failure Logging      

Support      
Backhaul QoS 
Status      

Maintenance 
Window Status      

TWAMP      

Event Log Status      
LTE Backhaul 
QoS Status      

LTE CBRS Status      
LTE UE Status 
and IP Throughput      

LTE eMBMS 
Status      

LTE Ethernet Per 
Port Status      

LTE Event Log 
Status      

LTE Logical IP 
Interface Status      

LTE Maintenance 
Window Status      

LTE Network 
Element Status      

LTE SON Status      

LTE TWAMP      
Ethernet Per Port 
Status       

Location and 
Synchronization 
Status 

     

Relay WiFi Access 
Point Status       
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Status Type 

Node Type 

eNodeB iB440 
iB460 

Base/Term 
Relay 

Relay 
eNodeB 

iBridge2 

Link Acceptance 
Test      

Backhaul and 
Connected 
Devices Status 

     

Spectrum 
Analyzer      

Log      

Overview      

Diagnostic Tests      
6.  

Note: If you examine the status of a node that is not correctly connected to your network, 
you only have the option of viewing its Discovered Properties. All other status information 
will be unavailable as collecting it requires a live link to the node. 

4. Once you select a Status Type, the relevant information will be retrieved from the node. The 
fields and content shown on each screen are dependent on the type of the node you are 
examining. For example, different information will be retrieved for the RF Status of an eNodeB 
node when compared with an iB440 or iB460 Base/Term node. 

Note: The data shown on the Status tab is read only as it is retrieved from the node and 
displayed for information purposes only. 

5. When you have finished reviewing the status of your selected node, click Close to return to the 
Node List screen. 

9.3 How to Reboot a Node 

Netspan provides you with the capability to reboot a node remotely which may be required to force a 
provisioning change on a node or if an error condition has been raised which requires a reboot. 

To reboot a node: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 253: Node List Screen 
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2. Find the node you want to reboot in the node list. Filter the list of nodes using the Node Type 

drop-down field, if required, to limit the displayed nodes by type, such as: eNodeB, iBridge 

Base, or iRelay. 

3. Either double click the node or select it and click Manage. Either action opens the Node 
Management screen. Then, select the State and Control tab. 

Figure 254: Node Management Screen - State and Control Tab 

 

4. To reboot a node, you need to make appropriate selection in the Action field. The choices you 
have here depend on the node type you are rebooting. Every node type gives you the option to 
Reset Node, which reboots the individual node you have selected. Additionally, some node 
types (iBridge 400 Base and iBridge 460 Base) also give you the option to Reset RF (PHY) 
which resets the physical layer radio frequency rather than rebooting the node. Choose your 
required option. 
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Figure 255: Action Options Field 

 

5. Making a selection in the Action field enables the Queue Action button. Click this to send your 
reset action to your selected node. You can review the progress of your requested action in the 
Statistics table. A reboot is not an instant action, it can take up to a minute for the request to 
reach the node and for the node to respond as required. When first requested, your action 
registers in the Pending column. When it is received by the node, it progresses to the Queued 
column while it awaits action to be taken. While the reboot is in progress, it registers in the 
Awaiting Response column. If there is an error during reboot, the value in the Failed column 
increments. Investigation is usually required to find the cause of the failure and examine the 
Events and Active Alarms menu options for further details. 

Figure 256: Statistics Table 

 

6. Click Cancel Actions if you want to cancel your reset request. 

7. Click Close to return to the Node List screen. 
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9.4 How to Change Service Status of a Node 

A node has a service status of either ‘in service’, meaning it is available for operation, or ‘out of service’, 
whereby even though it is visible in your network, it is not available for operation. The Netspan UI 
enables you to change the service status of a node so that you can take it out of service to make 
configuration changes and, once completed, return the node to service. 

To change the service status of a node: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 257: Node List Screen 

 

2. Find the node you want to change the service status of in the node list. Filter the list of nodes 
using the Node Type drop-down field, if required, to limit the displayed nodes by type, such as 
eNodeB, or iBridge Base. 

3. Either double click the node or select it and click Manage. Either action opens the Node 
Management screen. Then, select the State and Control tab. 

Figure 258: Node Management Screen - State and Control Tab 
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4. On this tab is a Service State panel. Under the Current Configuration heading, you can see 
the current status of your selected node, whether it is In Service or Out of Service. 

Figure 259: Service State Panel 

 

5. If the node is currently In Service and you want to change its status, then click Out of Service. 
Similarly, if the node is currently Out of Service and you want to change its status, then click In 
Service.  

a. Once you click In Service, a confirmation message will be displayed. Click Yes to confirm. 

Figure 260: Confirmation Screen – In Service 

 

b. Once you click Out of Service, a confirmation message will be displayed. Select 
appropriate option. 

Figure 261: Confirmation Screen - Out of Service 

 

6. When you have made your selection, click Save to action your change. The entries in the 
Current Configuration and Last Requested State fields will change automatically to reflect 
your update. 

7. Click Close to return to the Node List screen. 

9.5 How to Reprovision a Node 

Reprovisioning is the process whereby you resend a set of provisioning parameters to a given node to 
ensure that they have been applied. The Netspan UI provides you with the capability to reprovision a 
node through the Node Management screen.   

To reprovision a node: 

1. Choose Configuration Management > Node > Node menu option. This will open the Node 
List screen containing the nodes currently visible on your network. 

Figure 262: Node List Screen 
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2. Find the node you want to reprovision in the node list. Filter the list of nodes using the Node 
Type drop-down field, if required, to limit the displayed nodes by type, such as eNodeB, iBridge 
Base, or iRelay. 

3. Either double click the node or select it and click Manage. Either action opens the Node 
Management screen. Then, select the State and Control tab. 

Figure 263: Node Management Screen - State and Control Tab 

 

4. To reprovision a node, click the Re-provision button. This button is present on the State and 
Control tab for all node types.  

Figure 264: Reprovision Options Field 
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Figure 265: Reprovision Options Field for eNodeB 

 

Table 39. Reprovision Option Field 

Node Type Re-provision Actions 

eNodeB No options 

Cold Reset Node 

Forced Cold Reset Node 

Forced Reset Node 

Renew Operator Certificate 

Reset Node 

Run Script (eNodeB) 

iBridge 440 No options Reset Node 

iBridge 460 No options Reset Node 

Relay No options 

Reset Node 

Force Scan (Relay) 

Forced Cold Reset Node 

Relay eNodeB 

Node 

eNodeB 

Relay 

Cold Reset Node 

Force Scan (Relay) 

Forced Cold Reset Node 

Forced Reset Node 

Renew Operator Certificate 

Reset Node 

Run Script (eNodeB) 

Scan (Relay) 

Tamper Detect Reset 

iBridge2 No options 

Reset Discovery (Auto) 

Reset Discovery (Manual) 

Reset Node 

5. Clicking Reprovision sends your requested action to your selected node. You can review the 
progress of your requested action in the Statistics table. When first requested, your reprovision 
action registers in the Pending column. When it is received by the node, it progresses to the 
Queued column while it awaits action to be taken. While the reprovision takes place, it registers 
in the Awaiting Response column. If there is an error during the reprovision, the value in the 
Failed column increments. Investigation is usually required to find the cause of the failure and 
examine the Events and Active Alarms menu options for further details. 

Figure 266: Statistics Table 
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6. Click Cancel Actions if you want to cancel your reprovision request. 

7. Click Close to return to the Node List screen. 

9.6 How to Receive Updates from a Node 

Netspan pulls a lot of monitoring and management information from the node population connected to 
your network. This data is then displayed on various tabs on the Node Management screen. While 
polling nodes for information is an automated process, you have the option of manually forcing an 
update from a particular node to refresh the data displayed in the UI so that you have a completely up-
to-date view of the current situation on the node. 

To receive updates from a node: 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Figure 267: Node List Screen 

 

2. Find the node you want to edit in the node list. Filter the list of nodes using the Node Type 
drop-down field, if required, to limit the displayed nodes by type, such as eNodeB, or iBridge 
Base. 

3. Click the node to select it and click Manage. This opens the Node Management screen. Of 
the tabs available on this screen, several provide you with an Update from Node button. Click 
this to pull real-time data from your selected node which will be updated on the tab you are 
viewing. The tabs that have these options are: 

o State and Control (on the Service State panel for iBridge 440 Base, eNodeB, iBridge2, 
iBridge Base, and Relay eNodeB). 

o Software (on the Current Software Status panel for all node types apart from iBridge 
440). 

o Inventory (all node types). 

o Status (all node types). 

o Statistics (all node types). 

Note: On the Software tab, the button is labelled Update from Equipment rather than 
Update from Node. 

4. When you have finished reviewing the updated information from the node, click Close to return 
to the Node List screen. 
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9.7 How to Edit a Node 

The Netspan UI provides you with the ability to change the configuration parameters of a node so that 
its operation can be updated, such as applying a revised profile or changing its managed status. 

To edit a node: 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Figure 268: Node List Screen 

 

2. Find the node you want to edit in the node list. Filter the list of nodes using the Node Type 
drop-down field, if required, to limit the displayed nodes by type, such as eNodeB or iBridge 
Base. 

3. Click the node to select it and click Edit. This opens the Edit Node screen. From here, you can 
change the node parameters as required. See ARD-D00741 Netspan Parameters Reference 
Guide for a detailed description of the node parameters displayed on this screen, including the 
valid ranges of values and whether changing the parameter will have a direct impact on the 
service provided. 

Note: The parameters shown on the Edit Node screen are dependent on the type of the node 
you are editing. Not all parameters are applicable to all types of nodes. 

You can also edit multiple nodes together. In order to perform this operation, you can click 
Edit All on the All Nodes List screen or you press Ctrl + click the nodes that you want to 
edit and then click Edit. 
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Figure 269: Edit Node Screen 

 

4. When you have made your changes, click OK to commit them. This will close the Edit Node 
screen and you will be returned to the Node List. 

9.8 Multi Edit Nodes  

The Netspan UI also provides you with the ability to change the configuration parameters of multiple 
nodes together so that its operation can be updated simultaneously and same changes can be 
implemented throughout all the selected nodes.  

There are two methods by which you can edit multiple nodes: 

9.8.1 Managing Nodes 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Note: This process can also be performed for Node Search, Node Inventory, and Node RF.  

For Node Search: on the main Netspan menu, choose Configuration Management > Node 
> Node Search. 

For Node Inventory: on the main Netspan menu, choose Configuration Management > 
Node > Node Inventory. 

For Node RF: on the main Netspan menu, choose Configuration Management > Node > 
Node RF. 
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Figure 270: Node List Screen 

 

2. Find the nodes you want to edit in the node list. Press and hold Ctrl + click multiple nodes to 
select or press and hold Shift + select an array of nodes that you want to edit. Then, click 
Manage. 

Figure 271: Node List Screen 

 

3. This opens the Node Management page. Click the drop down option to display the nodes that 
you have selected for editing as shown in Figure 272.   

Figure 272: Multiple Node Management 
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4. Click Multi Edit to simultaneously edit the selected nodes. 

Figure 273: Multiple Node Management 

 

5. The Edit Multiple Nodes page will be displayed. You can set values for your selected nodes on 
this page and the same changes will be implemented to all nodes simultaneously. 

Figure 274: Editing Multiple Nodes 

 

6. Once you edit the parameters for these nodes, click Save. 
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9.8.2 Editing Nodes 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Note: This process can also be performed for Node Search, Node Inventory, and Node RF.  

For Node Search: on the main Netspan menu, choose Configuration Management > Node 
> Node Search. 

For Node Inventory: on the main Netspan menu, choose Configuration Management > 
Node > Node Inventory. 

For Node RF: on the main Netspan menu, choose Configuration Management > Node > 
Node RF. 

Figure 275: Node List Screen 

 

2. Find the nodes you want to edit in the node list. Press and hold Ctrl + click multiple nodes to 
select or press and hold Shift + select an array of nodes that you want to edit. Then, click 
Edit. 

Figure 276: Node List Screen 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  178 

3. The Edit Multiple Nodes page will be displayed. You can set values for your selected nodes on 
this page and the same changes will be implemented to all nodes simultaneously. 

Figure 277: Editing Multiple Nodes 

 

4. Once you edit the parameters for these nodes, click Save to save the changes. 

9.9 Multi Manage Nodes 

There can be scenarios where you need to update multiple nodes together. The Netspan UI provides 
you with the ability to do this quickly and efficiently.  

9.9.1 Managing Nodes 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Note: This process can also be performed for Node Search, Node Inventory, and Node RF.  

For Node Search: on the main Netspan menu, choose Configuration Management > Node 
> Node Search. 

For Node Inventory: on the main Netspan menu, choose Configuration Management > 
Node > Node Inventory. 

For Node RF: on the main Netspan menu, choose Configuration Management > Node > 
Node RF. 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  179 

Figure 278: Node List Screen 

 

2. Find the nodes you want to manage in the node list. Press and hold Ctrl + click the nodes to 
select them or press and hold Shift + select an array of nodes that you want to manage. 
Then, click Manage. 

Figure 279: Node List Screen 

 

3. This opens the Multiple Node Management page.  

Figure 280: Multiple Node Management 
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4. On this page, for the nodes selected, you can perform the following: 

o Neighbour Management tab: Add/delete a neighbor (refer How to Manage LTE 
Neighbour List). 

o State and control tab: Re-provision node, change the service status, and receive 
updates for a node (refer Node Management). 

o Software tab: View software details for the node selected, upgrade the software of the 
selected node, and upgrade multiple nodes (refer Software Upgrade).  

o Inventory tab: Examine the inventory for the selected node (refer How to Obtain 
Node/Network Inventory). 

o Alarms/Events tab: View and edit alarms and events (refer Alarm Management / Event 
Management). 

o Status tab: Examine the current status of the node across multiple operational categories 
(refer How to Examine Node Status). 

o Statistics tab: View performance statistics of a node (refer Performance Management). 

9.10 How to Delete a Node 
There may be times when you need to remove a node from your network. The Netspan UI provides you 
with the ability to do this quickly and efficiently.  

There are two potential scenarios in which you might need to delete a node: 

 Case 1: Delete a node completely from Netspan with the requirement to keep the node in 
service (for example, if the node needs to be moved from one Netspan instance to another).  

 Case 2: Delete a node completely from Netspan with the requirement to set the node to out of 
service. 

Case 1: If you only want to delete a node completely from Netspan with the requirement to keep the 
node in service, perform the following steps: 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Figure 281: Node List Screen 

 

2. Find the node you want to delete in the node list. Filter the list of nodes using the Node Type 
drop-down field, if required, to limit the displayed nodes by type, such as eNodeB or iBridge 
Base. 

Note: For an iBridge node, make sure to select a feeder base. The procedure detailed here 
should be performed on the feeder base. You cannot perform it on a feeder terminal. 

You can also delete multiple nodes together. In order to perform this operation, you can click 
Manage All on the All Nodes List screen or you press Ctrl + click the nodes that you want 
to delete and then click Delete. 
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3. Before you delete a node, it must first have a status of ‘unmanaged’. One of the properties 
displayed on the Node List screen is whether the node is Managed. If the Managed toggle 
button is enabled, then it is managed; if the toggle button is disabled (not clicked), then it is 
unmanaged. If the node you want to delete is already unmanaged, then click the node to select 
it and click Delete. 

4. If you need to change the Managed status of the node, click the node to select it and click Edit. 
This opens the Edit Node screen. 

5. In the Node Properties panel, click the Managed toggle button to set the node to unmanaged. 
Click Save to save your changes and return to the Node List screen.  

Figure 282: Node Properties Panel 

 

6. Now that the node is unmanaged, select it in the node list and click Delete. 

Case 2: If you want to delete a node completely in Netspan with the requirement to set the node to out 
of service, perform the following steps: 

1. On the main Netspan menu, choose Configuration Management > Node > Node. The Node 
List screen will be displayed with a list of all the currently configured nodes in your system.  

Figure 283: Node List Screen 

 

2. In the node list, find the node you want to delete. You can filter the list of nodes using the Node 
Type drop-down field to limit the displayed nodes by type, such as eNodeB or iBridge Base. 
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Note: For an iBridge node, make sure to select a feeder base. The procedure detailed here 
should be performed on the feeder base. You cannot perform it on a feeder terminal. You 
can also delete multiple nodes together. In order to perform this operation, you can click 
Manage All on the All Nodes List screen or you press Ctrl + click the nodes that you want 
to delete and then click Delete. 

3. Click Manage at the bottom of the Node List page. 

4. On the succeeding Node Management page, select the State and Control tab. 

Figure 284: State and Control Tab 

 

5. In the Service State panel, click Out of Service. 

Note: This option is enabled only if the selected node is in the Managed state. 

Figure 285: Setting Node to Out of Service 

 

6. Click Save to complete the process of moving the node into the Out of Service state. 
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7. After moving the node to the Out of Service state, follow the procedure detailed in Case 1 to 

remove it from Netspan. 

9.11 How to Obtain Node/Network Inventory  

Netspan provides you with the ability to view the inventory of a node, i.e. a detailed examination of the 
hardware and software that combine to create a node.  

To review a node’s inventory: 

1. On the main Netspan menu, choose Configuration Management > Node > Node Inventory. 
The Node Inventory List screen will be displayed with a list of nodes currently configured in 
your system along with their hardware and software inventories.  

Figure 286: Node Inventory List Screen 

 

2. Find the node that you want to examine the inventory for in the node list, and either double click 
it or select it and click Manage. Either of these actions opens the Node Management screen 
for your selected node with the Inventory tab displayed.  

Figure 287: Inventory Tab 

 

3. The details shown on the Inventory tab will give you an analysis of the hardware and software 

that currently constitute the node’s operating profile. This information will be read from the node 

by Netspan and cannot be edited; it is for information and review purposes only. The details 

displayed on the tab are described in Table 40.  
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Table 40. Node Inventory Properties and Descriptions 

Property Description 

Node Name Name of the node. 

Item Number 
The instance of the inventory item for items that have the same port 
number. For example, SCRT instances 1 and 2 would share the same 
board number but have different serial numbers. 

Product Code 
The code identifying the individual product in this row of the table. This 
is an alpha-numeric string. 

Description A user-friendly description of the current inventory on the node. 

Board Number 
An octet string to identify the board number if relevant to this inventory 
type, e.g.900-02-450. 

Board Revision 
An octet string to identify the revision number of the board identified by 
the Board Number. 

Serial Number An octet string to uniquely identify the physical entity. 

Hardware Config Flags The hardware identifier information retrieved from the CPLD. 

Software Product Number 
An octet string to identify the software product running on the current 
inventory. The field is empty when there is no software installed or when 

the software does not have a product ID. 

Description (Software) 
A description of the current software inventory as entered by the 
embedded software. 

Software Version  

The current software version running on the inventory item. There may 
be different software versions running on different instances of the same 
inventory port number, e.g. reflecting software versions running on 

multiple SCRTs. 

Assembly Number A number identifying the assembly of this inventory item. 

Assembly Revision 
The revision number of the assembly identified by the Assembly 
Number. 

CLEI Code 
The Common Language Equipment Identification as defined by 
OEM/PM. 

Description 
(Manufacturing) 

A description of the current inventory as entered during manufacturing. 

Manufacturing Date 
The date on which the unit was manufactured, shown as a string in the 
format dd.mm.yyyy. 

Hardware MAC Address 
The MAC address of the front panel Ethernet of the node or another 
MAC address selected for the purpose of identification of this inventory 

item. Shown in the format nn:nn:nn:nn:nn:nn. 

Manufacturer Name The name of the company who manufactured the inventory item. 

Factory Code 
The factory code of the manufacturer, entered as a string, with a 
maximum of 6 characters. 

4. Click Export to export the node inventory you can currently see on the Inventory tab. Your 
browser shows a message asking if you want to open or save Export.csv, the Excel file 
generated by Netspan for export. Click Open or Save as appropriate. 

Figure 288: Export Excel File Message 
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5. If you choose Open, your machine will launch Excel and will display the exported file of 
inventory details. 

Figure 289: Excel File View (Example) 

 

6. If you choose Save, Netspan will display a confirmation message stating that List.xls has been 
downloaded.  

Figure 290: Export Confirmation Message 

 

7. From here, you have the option to Open the exported file, Open folder which will display a 
Browse dialog open at the exported file’s location, or View downloads which will open the View 
Downloads dialog in which you can open the exported file or go to its downloaded location.  

9.12 How to Set Trap Destinations 

During the normal course of operation, nodes raise events which notify Netspan that certain actions 
have taken place or that particular condition has occurred, such as node re-booting or losing 
communication. Netspan is notified of these events by SNMP traps, unsolicited messages sent from an 
agent (a node) to a server (Netspan) triggered automatically when certain conditions occur on a node. 
These messages are sent in data packages in SNMP format. You will be able to determine where this 
trap information is sent using Netspan UI. 
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To set trap destinations: 

1. On the main Netspan menu, choose Fault Management > Node Trap Destinations. The Edit 
Equipment Trap Destinations screen will be displayed which shows the currently configured 
trap destinations for your system.  

Figure 291: Edit Equipment Trap Destination Screen 

 

2. In the NMS Server Address fields at the top of the screen, select the Netspan IP address that 
you want to send the trap information to. Drop-down fields are provided for both IPv4 and IPv6 
address types, while it is likely that your network will operate on either one IP version or the 
other, Netspan can support a mixed network. These drop-down lists will be automatically 
populated by Netspan with the IP addresses of the existing server (or servers). 

3. The Node File Upload panel is relevant where your network includes eNodeB nodes. If an 
eNodeB experiences a significant problem, it can send additional diagnostic information to 
Netspan as well as the trap details. To enable this extra information to be sent, select the 
Enable from the drop-down option. This displays a File Upload Folder field. In this text field, 
enter the folder location on the Netspan server to which the file from the node should be written.   

Note: If you do not have eNodeB nodes in your network, you do not need to complete this 

step. 

Figure 292: Node File Upload Panel 

 

4. In the SNMP Trap Destinations panel, define the details of the IP addresses and ports that 
the nodes should send their trap information to. The fields you need to define are described in 
Table 41. 
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Table 41. SNMP Trap Destinations Fields 

Field Description 

Description 

A text field to enter a description for the trap destination you are 
defining. Note that default trap destinations will be pre-populated by 
Netspan for IPv4 and IPv6, depending on your network profile. These 
pre-defined descriptions are read only. 

IP Address 

A text field to enter the IP address of the server to which the trap 
information should be sent. The format of the IP address you enter 
here will alter the content of the Assign To field. If you enter an IPv4 

address, nn.nn.nn.nn, then an IPv4 Nodes option will be available in 
the assign to list. If you enter an IPv6 address, nn:nn:nn:nn:nn:nn, then 

an IPv6 Nodes option will be available. 

Note that default trap destinations will be pre-populated by Netspan for 
IPv4 and IPv6, depending on your network profile. These pre-defined 

addresses are read only. 

Destination Port 

For the pre-defined trap destinations, a drop-down list will be provided 
from which you can choose the port to send the trap information to. For 
trap destinations you will be creating, the field is a text entry field for 

you to enter the port number. 

Enabled 
A checkbox to determine whether the trap destination is active. Select 
it to enable the destination in that row of the table, leave it clear to have 
the destination defined but not active. 

Assign To 

A drop-down list in which you should select the nodes that will use your 
defined trap destination. You have the option of either assigning the 
destination to All Nodes or just those of IPv4 or IPv6 configuration. 

The presence of IPv4 or IPv6 in the list will be changed dynamically 
depending on the format of the IP address you entered in the IP 
Address field. If your address is in the form nn.nn.nn.nn, the IPv4 

option will be included. If it is in the form nn:nn:nn:nn:nn:nn, the IPv6 
option will be included. 

5. Click Apply to commit your defined trap destinations. 

9.13 Performing Hardware Swap  

9.13.1 iBridge440 Hardware Swap  

Note: The node has to be commissioned (please refer UG-D01013 – AirCAP Installation and User 
Guide) before the HW swap, as it is not PnP. 

To perform a hardware swap of iBridge440 node, follow the steps below: 

1. On the main Netspan menu choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system. 

2. Click Add below the task list. This opens the Add Discovery Task screen. 

3. Complete the fields according to the descriptions provided in Table 7. 

4. Once you have defined your discovery task, a Test panel will be displayed at the bottom of the 
screen. If you want to try your discovery task to see if it reaches the node(s) you are trying to 
discover, click Test in this panel. Results will be returned, showing whether the node has been 
discovered by Netspan. 
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Figure 293: Discovery Task Test 

 

5. Go to Configuration Management > Node > Node, the new node created will be displayed in 
the node list. Select the node you have discovered and click Edit. 

Figure 294: Node Management Screen 
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6. Click Configure button. 

Figure 295: Provisioning Tab 

 

7. Enter the name of the new node that you had discovered earlier. 

Figure 296: Hardware Swap Screen 

 

  



Netspan Operations Manual 

UGD-D01017 Airspan Commercial and Internal Use  190 

8. Click Save. 

Figure 297: Replaced Hardware Screen 

 

9. The updated node will be displayed in the node list. 

Figure 298: Node List Screen 

 

9.13.2 PnP Node Hardware Swap 

Note: This section is applicable to the nodes that support PnP functionality. 

1. Go to Configuration Management > Node > Node, the node list will be displayed. Select the 
node for which you need to perform this process and click Manage. 

2. One the Node Management page, click Edit to provision the node. Then, click Managed toggle 
button, this will display the Convert To PnP Configuration button. 

Figure 299: Edit Node Screen (Example) 
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3. Click Convert To PnP Configuration button. 

Figure 300: Figure 290: Edit Node Screen (Example) 

 

4. A Confirmation Request will be displayed. Click OK (this will move the configuration from the 
node provisioned list to PnP provisioning list). 

Figure 301: Confirmation Request 

 

5. Change the PnP related information to allow Netspan to discover the replaced node based on 
location of the node (where node supports GPS), Hardware ID (SN) of the replaced unit, or 
both.  

Figure 302: Plug and Play Properties (Example) 

 

6. Click Save to save the changes. Then, switch on the replaced/swapped node.  

Note: Steps 1-5 can be done in advance to actual replacement of units.  

7. On the main Netspan menu choose Server > Discovery Tasks. The Discovery Tasks screen 
will be displayed with a list of all discovery tasks currently defined in your system.  

8. Click Add below the task list. This opens the Add Discovery Task screen.  

9. Complete the appropriate fields. 

10. Once you have defined your discovery task, a Test panel will be displayed at the bottom of the 

screen. If you want to try your discovery task to see if it reaches the node(s) you are trying to 

discover, click Test in this panel. Results will be returned, showing whether the node has been 

discovered by Netspan.  
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Figure 303: Discovery Task Screen 

 

11. Go to Configuration Management > Node > Node, the new node created will be displayed 

in the node list.  

12. Select the node, for which you need to perform the hardware swap, and click Manage. Then, 

go to Provisioning tab of the node.  

Figure 304: Node Management Screen 
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13. Click Edit, then on the Edit Node screen click the Configure button. Enter the name of the 

new node that you had discovered earlier.  

Figure 305: Edit Node 

 

14. Click OK to save your changes.  

15. The updated node will be displayed in the node list.  

9.14 Core Dump Process              

Below are the steps to enable core dump in Netspan SR17.50. 

1. Go to Node Profiles > eNodeB > Management Profile and click Add. Alternatively, you can 
select the respective profile from the list and click Edit. 

2. On the eNodeB Management Profile page, go to the Fault Management section and enable 
Core Dump. 

Figure 306: Enabling Core Dump 
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3. Select appropriate File Upload Destination folder from the drop-down option.  

o Local Server: Select Local Server for Netspan and specify the File Upload Folder path. 

Figure 307: Selecting Local Server 

 

o Filer Server: Select Filer Server if you are uploading from FTP or SFTP and select the 
appropriate SFTP/FTP from the drop down option. 

Figure 308: Selecting File Server 

 

9.14.1 Data Logger 

Follow the procedure below to upload log files to Netspan. 

1. If you need to monitor any specific log, then select the required node from node list and click 
Manage. Then, go to Data Logger on the State and Control tab.  

Figure 309: Data Logger 
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2. Under Data Logger, click Enable Data Logger. 

Figure 310: Enable Data Logger 

 

3. Specify the duration for which you want to monitor the log and click Enable.  

Figure 311: Set Duration for Logging 

 

4. If you need to stop tracking, then you can also disable the Data Logger by clicking Disable data 
Logger. Click Yes on confirmation request screen. 

Figure 312: Confirmation Request 
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10 Event Management 

A Netspan event is a notification indicating the occurrence of a condition on the Netspan server or any 
of the nodes in your network, for example a Channel Action Error, where the node reports a change in 
its status per channel. 

The following conditions can raise a Netspan event: 

 Receipt of an SNMP trap or notification by Netspan. 

 Transmission of any internal Netspan notification by any Netspan component. 

 Occurrence of a significant change (for example, rebooting the server or change of an alarm 
status). 

Note: This chapter applies to the following Netspan managed nodes: 

 eNodeB 

 iBridge  

 iRelay 

 Relay eNodeB 

Events can be notifications of normal operating procedures, such as a node being restarted, and does 
not have to be indicated that there is an error condition. Events that notify Netspan of fault conditions 
raise alarms. So an alarm being raised will always be triggered by an event, but not all events raise 
alarms. For details on managing alarms in Netspan, see Alarm Management. 

Depending on the event severity, Netspan will raise an alarm until the underlying condition is cleared. 
Resolving a fault in the network clears the associated alarm, but an event remains until it is expired 
from Netspan’s event buffer. 

Netspan stores events in its database. The Netspan events buffer can store up to a maximum of one 
million events. 

This section explains how to: 

 How to View Events 

 How to View and Edit Event Types 

 How to Export Events View into an Excel File 

 How to Understand Event Details 

 Filtering Events 

10.1 How to View Events 

Events, whether reporting routine node operation or a more significant error condition, are raised on 
nodes in the network and reported to Netspan. Assuming the event type in question has logging 
enabled, then details of the event are written in the Netspan event database and are displayed on the 
Events screen of the UI where you can view them to find out further details. 

Note: For a full description on event types that can be triggered and reported in the Netspan UI, 
see ARD-D00742 Netspan Alarms and Events Reference Guide.  
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To view the list of existing events: 

1. On the main Netspan menu, choose Fault Management > Events. The Events List screen 
will be displayed which lists the current events in your network. The default layout settings sort 
the events by date with the latest events being displayed first. 

Figure 313: Events List Screen 

 

2. The events list could potentially contain thousands of events. So, the Netspan UI enables you 
to refine the list using the Filters field to make it easier for you to find events of a particular 
type, from a particular source, or that have been raised within a particular time frame. The 
options available in the Filter drop-down list are described in Table 42. 

Table 42. Event Filter Criteria 

Criterion Description 

Received Time 
Displays the events received in a certain date and time with a search 
condition. 

Event Type Displays the events that match your specified event type.  

Source Type Displays the events that match your specified source type.  

Hardware Type Displays the events that match a hardware type. 

Source Displays the events that match a source name (node name). 

MAC Address Displays the events that match a MAC address (node MAC address). 

Unique ID Name Displays the name of the events that match a unique ID name.  

Unique ID Displays the events that match a unique ID value. 

Event Info Displays the events that match the event info with a search condition. 

Event Status 
Displays the events that match a specific status with a search 
condition. 

3. In addition to the Filter field, the Netspan UI also provides you with a Search option so that you 

can interrogate the events list for a particular keyword or term. To do this, click on the Filter 

checkbox, select appropriate option from a list of drop-down options available, and then click 

on Search.  

Note: The search may take a little while to return results depending on the number of events 
present in Netspan. 
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10.2 How to View and Edit Event Types 

Netspan contains many different event types. While the names and ITU event types of these events 
are pre-configured and cannot be changed. You can control whether a particular event type has its Log 
and Forward properties enabled. Logging determines whether the event information is written on the 
Netspan database and is displayed in the UI, while forwarding controls whether Netspan forwards that 
event as an SNMP trap over the NBIF.  

Note: For a full list of the event types configured in a particular software release of Netspan, see 
ARD-D00742 Netspan Alarms and Events Reference Guide. 

To view and edit the details of an event type: 

1. On the main Netspan menu, choose Fault Management > Event Types. This will open the 
Event Types List screen, which contains all event types currently configured in your system.  

Figure 314: Events Types List Screen 

 

2. Click the event type you want to edit the details for. Double click the selected event or click the 
Edit button. Either action opens the Edit Event Type screen.  

Figure 315: Edit Event Type Screen 

 

Table 43 describes the fields on the Edit Event Type page. 

Table 43. Event Properties 

Property Description 

Properties 

Name 
Provides the name of the event type. 

Note: This field is read only. 
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ITU Event Type 

Specifies the ITU event type of the event, which can be one of the 
following: 

 Other 

 Communications Alarm 

 Quality of Service Alarm 

 Processing Error Alarm  

 Equipment Alarm 

 Environmental Alarm 

 Integrity Violation 

 Operational Violation 

 Physical Violation 

 Security Service or Mechanism Violation 

 Time Domain Violation 

Note: This field is read only. 

Log 

Specifies whether event logging is enabled or disabled. 

Note: For an event type, if you disable event logging, that event will not 
appear on the Events page. 

Forward 

Specifies whether event forwarding is enabled or disabled. 

Note: For an event type, if you enable event forwarding, Netspan forwards 

that event as an SNMP trap over the NBIF.  

Priority Specifies the priority of the event (Low, Medium, or High).  

Related Alarm Types 

Lists the linked alarm types for the selected event type. 

3. After editing the properties, click Save. Your changes will be committed and you will be returned 
to the Event Types List screen. 

10.3 How to Export Events View into an Excel File 

When you are working with events in Netspan, you have the option of either viewing various event 
details in Netspan UI or you can export them as an Excel file to your machine so that you can examine, 
sort, and interrogate them as you please. 

To export the events view into an Excel file: 

1. Choose Fault Management > Events menu option. This will open a List screen containing the 
current events in your network. 

Figure 316: Events List Screen 
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2. Click Export to export the events you can currently see on the Event List screen. Your browser 
will show a message asking if you want to open or save Export.csv, the Excel file generated by 
Netspan for export. Click Open or Save as appropriate. 

Figure 317: Export Excel File Message 

 

3. If you choose Open, your machine will launch Excel and will display the exported file of event 
details.  

Figure 318: Excel File View (Example) 

 

4. If you choose Save, Netspan will display a confirmation message stating that Export.csv has 
been downloaded. 

Figure 319: Export Confirmation Message 

 

From here, you have the option to Open the exported file, Open folder which will display a 
Browse dialog open at the exported file’s location, or View downloads, which will open the 
View Downloads dialog in which you can open the exported file or go to its downloaded location. 

10.4 How to Understand Event Details 

When you open the Events List screen, the Netspan UI will display details about the events in tabular 
format. The information shown in this table is described in Table 44.  

Table 44. Event List Screen Information 

Column Heading Description 

Received Time The date and time when the event information was received by Netspan. 

Event Type The type of the event. 

Source Type The equipment type on which the event took place. 

Hardware Type The applicable hardware type of the event. 
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Column Heading Description 

Source 
The name of the equipment on which the event took place. Where the event 
has taken place on a node, the name of the node is displayed as a hyperlink; 
follow the link to open the Node Management screen for that node. 

MAC Address The MAC address of the equipment on which the event took place. 

Unique ID Name Unique ID Name assigned for a specific event instance. 

Unique ID Unique ID assigned for a specific event instance. 

Event Info 
Provides further information about the particular instance of the event, such 
as status. 

Event Status 
Only visible to users with ‘Engineering’ authorisation privileges, to be used for 
troubleshooting purposes. 

10.5 Filtering Events 

On some occasions, you might find it convenient to display only events that match a qualified filter. The 
Alarms/Events tab on the Node Management page of each node allows you to display the following, 
depending on what you select in the Display Type drop-down list: 

 Events 

 Alarms 

 Alarm History 

 Alarm State History 

 Alarm Timeline 

When you select Events from the Display Type drop-down list to filter events, Netspan allows you to 
create a custom event filter based on one of the following properties: 

 Received Time 

 Event Type 

 Source Type 

 Source 

 MAC Address 

 Unique ID Name 

 Unique ID 

 Event Info 

 Event Status 

This Netspan feature helps you refine the events list to only display the events that you are interested 
in.   
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To create a custom event filter: 

1. On the Netspan main menu, select Configuration Management > Node > Node. The Nodes 
List page appears. 

Figure 320: Node List 

 

2. Double-click the node on which you want to apply event filtering and refine the Events list. The 
Node Management page appears. 

3. On the Node Management page, select the Alarms/Events tab, and then select Events from 
the Display Type drop-down list. 

Figure 321: Configuring Event Filtering 

 

4. Click the Filter toggle button to enable event filtering. 
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5. Customize your filter by making an appropriate selection in the property, comparer type and 
value boxes that appear when you enable the Filter checkbox.   

Figure 322: Configuring Event Filtering 

 

Compare types enhances the filter criteria by offering the ability to select specific parameter 
values. Depending on what comparison you want to perform, select the compare type. Each 
compare type has a unique function that is designed for making your node search simple, easy, 
and effective. For more information on the compare types that you can use to improve your 
event filtering process, see Table 45. 

The list of applicable compare types varies depending on the selected Property. 

Table 45. Compare Types 

Compare Type Function 

Last 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred in the past 24 
hours, one hour or 5 minutes. 

> 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred before the 
specified period. 

>= 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred before or during 
the specified period. 

< 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred after the 
specified period. 

<= 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred after or during 
the specified period. 

Between 
Note: This compare type applies to the 
Received Time property only. 

Returns a list of events occurred between the 
specified time range. 

= 
Note: This compare type does not apply to the 
Received Time property. 

Returns a list of events where the selected 
property matches the set value. 
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!= 
Note: This compare type does not apply to the 
Received Time property. 

Returns a list of events where the selected 
property does not match the set value. 

Starts with 
Note: This compare type does not apply to the 
Received Time property. 

Returns a list of events where the selected 
property starts with the substring that you 
specified in the Value field. 

Contains 
Note: This compare type does not apply to the 
Received Time property. 

Returns the details of the events where the 
selected property contains the substring that you 
specified in the Value field. 

Not Contains 
Note: This compare type does not apply to the 
Received Time property. 

Returns the details of the events where the 
selected property does not contain the substring 
that you specified in the Value field 

In List 
Note: This compare type does not apply to the 
Received Time property. 

Returns the details of the events where the 
selected property matches the values that you 
selected/typed/pasted using the Set List option. 
Tip: Use Ctrl + click to select multiple entries 
and Shift + click to select an array of entries. 
Note: Instead of selecting the items, if you want 

to type or paste a list of values, after selecting the 
Set List button, click the Advanced button. This 

opens a new window where you can type or paste 
your items. 
When you are in the Advanced mode, click the 
Basic button to revert to the Basic mode. 

Not in List 
Note: This compare type does not apply to the 
Received Time property. 

Returns the details of the events where the 
selected property does not match the values that 
you selected/typed/pasted using the Set List 

option 
Tip: Use Ctrl + click to select multiple entries 
and Shift + click to select an array of entries. 
Note: Instead of selecting the items, if you want 

to type or paste a list of values, after selecting the 
Set List button, click the Advanced button. This 

opens a new window where you can type or paste 
your items. 
When you are in the Advanced mode, click the 
Basic button to revert to the Basic mode. 

Is Set 
Note: This compare type applies to the Event 
Status property only. 

Returns the details of the events where the 
selected property is defined or set. 

Is Not Set 
Note: This compare type applies to the Event 
Status property only. 

Returns the details of the events where the 
selected property is not defined or set. 
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Example 1: 

In this example, event filtering is performed to retrieve a list of events that occurred during a specific 
time period. 

Figure 323: Applying Event Filter ─ Example 1 

 

Example 2: 

In this example, event filtering is performed to retrieve a list of PnP events. 

Figure 324: Applying Event Filter ─ Example 2 
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A Abbreviations 

Term Expansion 

Ack Acknowledge 

ANR Automatic Neighbor Relation 

APN Access Point Name 

BS Base Station 

CBRS Citizens Broadband Radio Service 

CGI Cell Global Identity 

CLEI Common Language Equipment Identification 

CMAS Commercial Mobile Alert System 

CoMP Coordinated Multipoint 

CPLD Complex Programmable Logic Device 

CQI Channel Quality Indicator 

CSFB Circuit Switched FallBack 

CSG Closed Subscriber Group 

EARFCN E-UTRA Absolute Radio Frequency Channel Number 

ECI E-UTRAN Cell Identifier 

eMBMS Evolved Multimedia Broadcast Multicast Services 

EMS Element Management System 

eNB eNodeB 

eNodeB Evolved Node B 

E-RAB E-UTRAN Radio Access Bearer 

ETWS Earthquake and Tsunami Warning System 

FDD Frequency Division Duplex 

FTP File Transfer Protocol 

GPS Global Positioning System 

GTP GPRS Tunneling Protocol 

GUI Graphical User Interface 

HARQ Hybrid Automatic Repeat Request 

HO  Handover 

ID Identity Document 

IIS Internet Information Services 

IP Internet Protocol 

IPv4 Internet Protocol Version 4 

IPv6 Internet Protocol Version 6 

ITU International Telecommunication Union 

KPI Key Performance Indicators 

LOS Line of Sight 

LTE Long Term Evolution 
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MAC Media Access Control 

MCC Mobile Country Code 

MCS Modulation Coding Scheme 

Mgmt Management 

MME Mobility Management Entity 

MNC Mobile Network Code 

MNO Mobile Network Operator 

MSB Most Significant Bit 

MVNO Mobile Virtual Network Operator 

N/A Not Applicable 

NBIF Northbound Interface 

NE Network Element 

NLOS Non Line of Sight 

NMS Network Management System 

NOC Network Operations Center 

OEM Original Equipment Manufacturer 

OS Operating System 

PC Personal Computer 

PCI Physical Cell Identity 

PDCL Priority Donor Cell List  

PDN Packet Data Network 

PHY Physical 

PLMN Public Land Mobile Network 

PM Performance Management 

PnP Plug and Play 

QCI QoS Class Identifier 

QoS Quality of Service 

RACH Random Access Channel 

RF Radio Frequency 

RNC Radio Network Controller 

RRC Radio Resource Control 

RSRP Reference Signal Received Power 

RSRQ Reference Signal Received Quality 

SAS Spectrum Allocation Servers 

SCRT Single Channel Radio Transceiver 

SFTP Secure File Transfer Protocol 

SN Sequence Number 

SNMP Simple Network Management Protocol 

SOAP Simple Object Access Protocol 

SON Self-Organizing Network 

SQL Structured Query Language 
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SS Subscriber Station 

SW Software 

TAC Tracking Area Code 

TDD Time Division Duplex 

TFTP Trivial File Transfer Protocol 

TWAMP Two-Way Active Management Protocol 

UARFCN UTRA Absolute Radio Frequency Channel Number 

UDP User Datagram Protocol 

UE User Equipment 

UI User Interface 

UMTS Universal Mobile Telecommunication System 

UTRA Universal Terrestrial Radio Access 

UTRAN Universal Terrestrial Radio Access Network 

V2C Version 2C 

V3 Version 3 

VLAN Virtual Local Area Network 

VoLTE Voice over Long-Term Evolution 

Wi-Fi Wireless Fidelity 

XML Extensible Markup Language 
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